MonoX support board

Start the conversation, ask questions and share tips and solutions with fellow developers.

Non-registered users can only browse through our support boards. Please register now if you want to post your questions. It takes a second and it is completely free. Alternatively, you can log in without registration using your credentials at major sites such as Google, Microsoft Live, OpenId, Facebook, LinkedIn or Yahoo.

Mono X on azure website  (Mono Support )

Viewed 14937 time(s), 12 post(s) 3/18/2015 5:01:05 PMby rkulkarni
rkulkarni

rkulkarni

3/20/2015 10:52:55 AM
Re-started the website. It is working now! Thank you.
This content has not been rated yet. 
46 Reputation 7 Total posts
rkulkarni

rkulkarni

3/18/2015 5:01:05 PM
I have deployed Mono X on an Azure website. User sign up is not working. Please suggest a solution.

Thanks
Rahul
This content has not been rated yet. 
46 Reputation 7 Total posts
khorvat

khorvat

3/18/2015 10:05:44 PM
Can you please let us know if you have deployed to VMs or WebRoles ?

Thanks
This content has not been rated yet. 
15993 Reputation 2214 Total posts
rkulkarni

rkulkarni

3/18/2015 10:49:48 PM
Neither web role nor the VM, I have used Azure Websites.
This content has not been rated yet. 
46 Reputation 7 Total posts
vzakanj

vzakanj

3/19/2015 2:35:00 PM
Hi rkulkarni,
can you please state which version of MonoX is in question here.

Thanks,
Vedran
This content has not been rated yet. 
345 Reputation 61 Total posts
rkulkarni

rkulkarni

3/19/2015 2:45:41 PM
MonoX v4.9.40.4906
DB v4.7.3842

This is the default version when i deploy MonoX using Create Azure Website wizard. 
Screenshot attached.
This content has not been rated yet. 
46 Reputation 7 Total posts
vzakanj

vzakanj

3/19/2015 3:03:13 PM
Have you checked the MonoX logs, located in MonoX\ApplicationData\Logs ?

If the problem is not obvious there, please post the logs here.

Regards,
Vedran
This content has not been rated yet. 
345 Reputation 61 Total posts
rkulkarni

rkulkarni

3/19/2015 4:06:54 PM
I have not checked the logs yet. This is a template provided on Azure.
Isn't it expected to work??
This content has not been rated yet. 
46 Reputation 7 Total posts
vzakanj

vzakanj

3/19/2015 4:11:09 PM
It could be failing for reasons like bad/missing SMTP configuration and similar. Check the logs for specific details.

Regards,
Vedran
This content has not been rated yet. 
345 Reputation 61 Total posts
rkulkarni

rkulkarni

3/20/2015 8:34:30 AM
Okay, i had a look at the logs. The request is timing out. 

2015-03-20 08:33:20,127 [52] ERROR MonoX [115.113.11.220] - Error
System.ApplicationException: An uexpected error has occured while sending you an activation e-mail. Your account has been successfully created but you can't login until you activate it via activation e-mail. To resend your activation e-mail please go to the <a href="/Membership/ActivationEmailRecovery.aspx">Activation e-mail recovery</a> page. If the problem persists, please contact us. ---> System.ApplicationException: An error has occured while sending you an e-mail. Please try again, if the problem persists, please contact us. ---> System.Net.Mail.SmtpException: The operation has timed out.
at System.Net.Mail.SmtpClient.Send(MailMessage message)
at MonoSoftware.Core.Mail.MailSender.SendMail(MailMessage mailMsg)
--- End of inner exception stack trace ---
at MonoSoftware.MonoX.Mail.MonoXMailSender.SendMail(MailMessage mailMsg)
at MonoSoftware.Core.Mail.MailSender.SendMail(MailAddress fromAddress, String toAddress, String title, String htmlContent, String plainContent)
at MonoSoftware.Core.Mail.MailSender.SendMail(String toAddress, String title, String htmlContent, String plainContent)
at MonoSoftware.MonoX.ModuleGallery.MembershipEditor.#Jp(Object sender, EventArgs e)
--- End of inner exception stack trace ---
at MonoSoftware.MonoX.ModuleGallery.MembershipEditor.#Jp(Object sender, EventArgs e)
at MonoSoftware.MonoX.Controls.StyledButton.OnClick(Object sender, EventArgs e)
at MonoSoftware.MonoX.Controls.StyledButton.#Ho(Object sender, EventArgs e)
at System.Web.UI.WebControls.LinkButton.OnClick(EventArgs e)
at System.Web.UI.WebControls.LinkButton.RaisePostBackEvent(String eventArgument)
at System.Web.UI.WebControls.LinkButton.System.Web.UI.IPostBackEventHandler.RaisePostBackEvent(String eventArgument)
at System.Web.UI.Page.RaisePostBackEvent(IPostBackEventHandler sourceControl, String eventArgument)
at System.Web.UI.Page.RaisePostBackEvent(NameValueCollection postData)
at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
2015-03-20 08:33:20,502 [52] ERROR MonoX [BaseHttpApplication] - Application Error
System.Web.HttpException (0x80004005): Request timed out.
This content has not been rated yet. 
46 Reputation 7 Total posts
rkulkarni

rkulkarni

3/20/2015 8:42:26 AM
Here's my SMTP configuration

<smtp deliveryMethod="Network" from="*****">
      <network host="smtp.yahoo.com" userName="******" password="****" port="587" enableSsl="true" defaultCredentials="false" />
 </smtp>
This content has not been rated yet. 
46 Reputation 7 Total posts
1 2