MonoX support board

Start the conversation, ask questions and share tips and solutions with fellow developers.

Non-registered users can only browse through our support boards. Please register now if you want to post your questions. It takes a second and it is completely free. Alternatively, you can log in without registration using your credentials at major sites such as Google, Microsoft Live, OpenId, Facebook, LinkedIn or Yahoo.

How to make socialize menu tab and pages visible to everyone?  (Mono Support )

Viewed 6309 time(s), 5 post(s) 12/31/2012 6:51:45 PMby super
super

super

12/31/2012 6:51:45 PM
How to make socialize menu tab and pages visible to everyone?

Right now in menu tab "socialize" menu tab is only visible and accessable to registered users.

I want to make it public because without registering noone will ever know that this feature is there on the website.

I changed the settings in administration - pages - Socialize - role settings, UNCHECKED "users" . now the menu tab is visible but when I click on it (without login), I get the login screen and monox project asks me to login first, why ?

How to solve this issue ?

Also...making this public doesn't mean that anyone can post anything ...the rest of the flow should remain same that for posting, anyone needs to registered first but at least it should be viewable to everyone.
This content has not been rated yet. 
6018 Reputation 709 Total posts
denis

denis

1/3/2013 6:40:24 PM
Are we taling about the new version of that page (4.7)? Some of the functionality on that page did not really make sense for nonauthenticated users in the old versions (it included a friend list part, etc).
It shoud work as you want in the new version - when all roles are unchecked, it should let the unauthenticated users in.
This content has not been rated yet. 
7207 Reputation 956 Total posts
super

super

1/11/2013 8:52:20 PM
Yes, I have the latest nightly build 4.7 (9/1/2013) - I have unchecked the role "Users" by going to admin - pages - let's socialize

Now "Lets socialize" menu tab is visible to everyone BUT, when any user click on it - it still ask the user to login first ? why ? if it possible to make this page accessible to public (non-users) ? if yes, HOW ?
This content has not been rated yet. 
6018 Reputation 709 Total posts
khorvat

khorvat

1/12/2013 8:44:54 AM
Hi, there are permissions for navigation, the one you checked, and page permissions that you can get by right clicking on the right grid items and by opening page properties.
This content has not been rated yet. 
15993 Reputation 2214 Total posts
super

super

1/12/2013 12:23:03 PM
khorvat, I just solved this problem by using chrome - I was not able to solve this problem because I never saw "Socialize" in pages (in admin) because of this Internet Explorer bug that I just reported HERE
This content has not been rated yet. 
6018 Reputation 709 Total posts