MonoX support board

Start the conversation, ask questions and share tips and solutions with fellow developers.

Non-registered users can only browse through our support boards. Please register now if you want to post your questions. It takes a second and it is completely free. Alternatively, you can log in without registration using your credentials at major sites such as Google, Microsoft Live, OpenId, Facebook, LinkedIn or Yahoo.

Change Default Language  (Mono Support )

Viewed 27186 time(s), 4 post(s) 10/7/2014 11:13:21 AMby fdiama
fdiama

fdiama

10/7/2014 11:13:21 AM
Hello,

I'm trying to change the default language, using "Language Manager" functionality (setting default language e.g. "italian"), but seems doesn't work; 

It works only if I set the localized url using "language" dropdown (url "lng/it-IT/Default.aspx"), but without localization folder in url, system always send me the english version of the portal;

have I missing something?

thanks in advance
This content has not been rated yet. 
107 Reputation 11 Total posts
dbogdan

dbogdan

10/7/2014 12:17:47 PM
Hi Fdiama,

First of all, please could you tell us which MonoX version you use?

Also, could you please try to restart application in IIS, after you change your language settings to Italian.

Regards,
Darjan
Rated 5.00, 1 vote(s). 
231 Reputation 38 Total posts
fdiama

fdiama

10/7/2014 1:04:31 PM
Thanks for the trick!

I've restarted IIS App pool and it works successfully.

(Version: MonoX v5.1.40.5028 [12/09/2014], DB v4.7.3842)
This content has not been rated yet. 
107 Reputation 11 Total posts
khorvat

khorvat

10/8/2014 7:26:49 AM
We will check if this is an issue in MonoX and get back to you.

Thanks for reporting this.
This content has not been rated yet. 
15993 Reputation 2214 Total posts