MonoX support board

Start the conversation, ask questions and share tips and solutions with fellow developers.

Non-registered users can only browse through our support boards. Please register now if you want to post your questions. It takes a second and it is completely free. Alternatively, you can log in without registration using your credentials at major sites such as Google, Microsoft Live, OpenId, Facebook, LinkedIn or Yahoo.

Facebook Login works successfully but not automatically login  (Mono Support )

Viewed 16526 time(s), 18 post(s) 11/19/2013 4:02:09 PMby bkkmono
mzilic

mzilic

11/20/2013 1:55:48 PM
Your settings appear to be OK. Aside from logging error messages SocialAuth keeps a debug log as well. Please zip the monox logs directory and post them here or send them to my e-mail address at mzilic@mono.hr

Regards,
Mario
This content has not been rated yet. 
2218 Reputation 300 Total posts
bkkmono

bkkmono

11/20/2013 2:23:54 PM
The email has been sent, please check your mail box. Thanks in advance.
This content has not been rated yet. 
434 Reputation 51 Total posts
mzilic

mzilic

11/20/2013 2:27:15 PM
Hello,

The way we understood your post was that nothing related to Facebook was generated in the logs. However per your e-mail nothing at all was logged which could mean that logging might not be working. Please check if you have web.log4net and please check that MonoX has write permissions to the ApplicationData directory.

Regards,
Mario
This content has not been rated yet. 
2218 Reputation 300 Total posts
bkkmono

bkkmono

11/20/2013 2:41:50 PM
Yes, my site has web.log4net and MonoX\ApplicationData directory has write permissions.
This content has not been rated yet. 
434 Reputation 51 Total posts
bkkmono

bkkmono

11/20/2013 3:09:53 PM
Right!.. After I granted write permissions for MonoX\ApplicationData directory again, log files were just created. Please check your email inbox.
This content has not been rated yet. 
434 Reputation 51 Total posts
mzilic

mzilic

11/20/2013 4:03:00 PM
Hello,

I've logged this problem onto our issue tracking system once the issue is resolved we will let you know. The problem appears to be related with the Facebook's Date of Birth parsing.

Regards,
Mario
This content has not been rated yet. 
2218 Reputation 300 Total posts
bkkmono

bkkmono

11/20/2013 4:11:56 PM
OK, thanks for your helps. I will wait you to resolve this issue.
This content has not been rated yet. 
434 Reputation 51 Total posts
mzilic

mzilic

11/21/2013 3:44:50 PM
Hello,

I believe we've narrowed down the problem and fixed it. The changes will be available in the next nightly build after the "2013-11-22 18:00:00 GMT+1".

Regards,
Mario
This content has not been rated yet. 
2218 Reputation 300 Total posts
1 2