MonoX support board

Start the conversation, ask questions and share tips and solutions with fellow developers.

Non-registered users can only browse through our support boards. Please register now if you want to post your questions. It takes a second and it is completely free. Alternatively, you can log in without registration using your credentials at major sites such as Google, Microsoft Live, OpenId, Facebook, LinkedIn or Yahoo.

Facebook Login works successfully but not automatically login  (Mono Support )

Viewed 16326 time(s), 18 post(s) 11/19/2013 4:02:09 PMby bkkmono
bkkmono

bkkmono

11/20/2013 9:02:02 AM
Hello,

I can successfully login to my site using Facebook Social Login, then it redirects to this address: http://www.mydomain.com/login.aspx?ReturnUrl=/#_=_ and display an error as  the attached image below. It doesn't automatically log in until I click the login button again.

How to fix this problem so that it will automatically login after successfully Facebook logging into the site?
This content has not been rated yet. 
434 Reputation 51 Total posts
imarusic

imarusic

11/20/2013 7:59:23 AM
Hi,

did you make any changes to the MonoX Social Login control? Did you extend it?

Regards.
This content has not been rated yet. 
3016 Reputation 428 Total posts
bkkmono

bkkmono

11/20/2013 8:16:46 AM
No, I never did anything.
This content has not been rated yet. 
434 Reputation 51 Total posts
tihomir-kit

tihomir.kit

11/20/2013 8:59:14 AM
Hi,

could you please tell us which version of monox are you using here so we could test it?

Thank you
This content has not been rated yet. 
526 Reputation 43 Total posts
bkkmono

bkkmono

11/20/2013 9:00:44 AM
My site is using MonoX v4.8.40.4594, DB v4.7.3842
This content has not been rated yet. 
434 Reputation 51 Total posts
mzilic

mzilic

11/20/2013 10:49:22 AM
Please post your MonoX error logs, the screenshot you posted indicates that there was possibly an error somewhere in the login process.

Regards
This content has not been rated yet. 
2218 Reputation 300 Total posts
bkkmono

bkkmono

11/20/2013 11:03:05 AM
It has not any message in the log file about this issue since it doesn't login automatically after completing the Facebook login process. I must click the login button again to able to access my account with the Facebook profile on my site. You could try to login using your Facebook account on my site: http://www.bangkokpeak.com , you would get an error.
This content has not been rated yet. 
434 Reputation 51 Total posts
tihomir-kit

tihomir.kit

11/20/2013 12:35:28 PM
Hi,

I could not reproduce your error using a vanilla installation of the exact same version of MonoX you're using. Does this happen for other providers as well?
This content has not been rated yet. 
526 Reputation 43 Total posts
mzilic

mzilic

11/20/2013 1:09:35 PM
Hi,

We would still like to take a look at the logs. Also can you please post a screenshot of your Facebook app settings from the developers.facebook.com page.

Regards,
Mario
This content has not been rated yet. 
2218 Reputation 300 Total posts
bkkmono

bkkmono

11/20/2013 1:40:18 PM
The screenshot is below.
This content has not been rated yet. 
434 Reputation 51 Total posts
1 2