MonoX support board

Start the conversation, ask questions and share tips and solutions with fellow developers.

Non-registered users can only browse through our support boards. Please register now if you want to post your questions. It takes a second and it is completely free. Alternatively, you can log in without registration using your credentials at major sites such as Google, Microsoft Live, OpenId, Facebook, LinkedIn or Yahoo.

Problem - page management  (Mono Support )

Viewed 13881 time(s), 4 post(s) 3/15/2011 11:34:44 AMby Helene
Helene

Helene

3/15/2011 11:34:44 AM
Hi

In the Page Management section when a new page (Default Template) is added, the title (Html Editor 1) of the webpat in the left side is visible to the publich site (when logged out as admin).

How can I fix that?

And there is no delete option for the editors - is that right?

Regards

This content has not been rated yet. 
315 Reputation 39 Total posts
denis

denis

3/15/2011 12:23:27 PM
Although it does not behave this way for the default page template in my installation, the title behavior is controlled by the Web part chrome - more specifically, by Web part zone properties ShowChromeForNonAdmins (which controls if the chrome is displayed to ordinary users) and ChromeTemplateFile (which points to the chrome template in /App_Templates/YourThemeName/PageTemplates/).

Web parts that are placed in the markup of the page cannot be deleted. You can create a page template with no parts at all and than use part catalog to place the parts dynamically.
This content has not been rated yet. 
7207 Reputation 956 Total posts
imarusic

imarusic

3/15/2011 12:31:02 PM
Hi Helene,

In order to remove the "Html Editor" title you need to set the "ShowChromeForNonAdmins" property, within your markup, to false or simply to remove that property, because it's set to false by default.

e.g.

<portal:PortalWebPartZone HeaderText="Left part zone" ID="leftWebPartZone" runat="server" Width="100%" ChromeTemplateFile="LeftColumn.htm" ShowChromeForNonAdmins="false">
           <ZoneTemplate>
                     <MonoX:Editor runat="server" ID="editor1" />            
            </ZoneTemplate>
</portal:PortalWebPartZone>


There are two ways to delete the editors.

1. If the editor resides in your markup then you can close it through it's "Visible" property(please see the attached image) or to delete it from your markup.

2. When you add the editor dynamically and then go to the design mode, you have "close" and "delete" options(please see the attached image). "Close" option will hide the editor, but "delete" option will remove the editor from the page.
This content has not been rated yet. 
3016 Reputation 428 Total posts
Helene

Helene

3/15/2011 1:42:36 PM
Hi again.

Thank you very much.

Now it works and I understand a little more:)

Regards
This content has not been rated yet. 
315 Reputation 39 Total posts