MonoX support board

Start the conversation, ask questions and share tips and solutions with fellow developers.

Non-registered users can only browse through our support boards. Please register now if you want to post your questions. It takes a second and it is completely free. Alternatively, you can log in without registration using your credentials at major sites such as Google, Microsoft Live, OpenId, Facebook, LinkedIn or Yahoo.

MonoX will not Install on Windows 7: HTTP Error 500.19  (Mono Support )

Viewed 137957 time(s), 15 post(s) 1/10/2011 10:57:29 PMby yousaid

Related topics

yousaid

yousaid

1/10/2011 10:57:29 PM
There maybe an issue in the config file. All other Asp.Net Applications work fine and installs ok. With MonoX I get this error:
Module IIS Web Core
Notification BeginRequest
Handler Not yet determined
Error Code 0x80070005
Config Error Cannot read configuration file due to insufficient permissions
Config File \\?\C:\Users\cbian\Documents\My Web Sites\MonoX\web.config
Requested URL http://localhost:80/MonoX/MonoX/Installer/License.aspx
Physical Path C:\Users\cbian\Documents\My Web Sites\MonoX\Installer\License.aspx
Logon Method Not yet determined
Logon User Not yet determined

HTTP Error 500.19 - Internal Server ErrorThe requested page cannot be accessed because the related configuration data for the page is invalid.

The error seems to indicate a permissions issue, but I have checked and Network Services have full permissions to the folder and and webdonfig.
The AppPool is fine too and Virtual directory is fine.
Here is what I did.
Downloaded the new build today (2) Unzipped (3) Cretated a New Folder and named it Monox (4)Using the Properties window, I granted full read\write permissions to NetworkService Account. (5) Start inetMgr and created an Application. (6)Verified that the appPool is configured for .Net 4 Framework. (7) Go to SQL created an Empty DB and granted same Network service account in Step 4 full access (dbo)
Finally, Copied the 4.0 config from the samples folder and updated it to use my DB.

The only change I made is to this line:


NOTE: I am not doing any custom app. I just want to run the downloaded app. (contents of the Zipped file)

cheers,
yousaid
This content has not been rated yet. 
206 Reputation 36 Total posts
denis

denis

1/11/2011 10:49:03 AM
It is either a permision issue, or a misconfiguration issue (a typo in the web.config you made while editing it). I can confirm that web.config for .NET 4.0 works without problems as is.
1. permisions: application pools in IIS 7 or higher by default run under special account called ApplicationPoolIdentity, not a NetworkService account that was used in previous versions. When assigning properties you may use the default account (it will have a name of the app pool), or switch to NetworkService by right clicking on the app pool in IIS admin, Advanced settings, and select NetworkService in the Identity field.
2. configuration: you don't have to make any changes when copying the .NET web.config if you are not doing an upgrade from .NET 2. Just copy it over the old config file and access the app, which should start the installation.

If this doesn't help, please send us your config file and we will troubleshoot it.
This content has not been rated yet. 
7207 Reputation 956 Total posts
yousaid

yousaid

2/14/2011 9:36:08 PM
Still the same following your directions.

If I DON'T update the config to use my newly created DB, I get this
---------------------------------------------------------------------
Configuration Error
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Unrecognized element 'folderLevelBuildProviders'.

Source Error:


Line 376:
Line 377:
Line 378:
Line 379:
Line 380:

Source File: C:\Windows\Microsoft.NET\Framework64\v2.0.50727\Config\web.config Line: 378

NOTICE that this line above is referencing framework 2.xxx even though it is a copy of the 4.0 version from the samples folder
------------------------------------------------------------------------------------------

If I UPDATE the web.config to use my newly created DB, I get this error as before

--------------------------------------------------------------------------------
Version Information: Microsoft .NET Framework Version:2.0.50727.4952; ASP.NET Version:2.0.50727.4955
I still get this error:
HTTP Error 500.19 - Internal Server ErrorThe requested page cannot be accessed because the related configuration data for the page is invalid.Detailed Error InformationModule IIS Web Core
Notification BeginRequest
Handler Not yet determined
Error Code 0x80070005
Config Error Cannot read configuration file due to insufficient permissions
Config File \\?\C:\Users\cbian\Documents\My Web Sites\MonoX\web.config
Requested URL http://localhost:80/MonoX/MonoX/Installer/License.aspx
Physical Path C:\Users\cbian\Documents\My Web Sites\MonoX\MonoX\Installer\License.aspx
Logon Method Not yet determined
Logon User Not yet determined


This content has not been rated yet. 
206 Reputation 36 Total posts
denis

denis

1/11/2011 5:56:07 PM
I'm quite sure that you did not switch the .NET framework version for the application pool MonoX is running under. It is still set to .NET 2.0, please switch it to .NET 4.0 in the IIS admin.
This content has not been rated yet. 
7207 Reputation 956 Total posts
yousaid

yousaid

1/11/2011 7:16:56 PM
Changed it again, still the same.
Can you try using the Webconfig I posted and let's see.?
Strange thing is that all other Apps works just fine and older installs of MonoX work fine too.

Before I uninstall IIS and reinstall, can you test the webconfig I have. If it works, then something is wrong with my box
cheers,
yousaid
This content has not been rated yet. 
206 Reputation 36 Total posts
denis

denis

1/11/2011 10:12:44 PM
Just tried that on my installation (changed only the LocalSqlConnection value) and it works. I am sure that you put the 4.0 config file while the app pool your MonoX installation is still running on 2.0 - that's why you get such error message.
This content has not been rated yet. 
7207 Reputation 956 Total posts
yousaid

yousaid

1/12/2011 4:23:36 AM
Yes, I believe something is wrong with my box. I have reinstalled IIS, still same issue. Strange thing is, all other .NET apps work and install ok.
Even more strange is that I can even Install using the Web Platform Installer, but the version on the wpi seems to be the older build.
So I guess I will have to wait till the new version is available on the platform installer.
Any Ideas when that will be?

cheers,
yousaid
This content has not been rated yet. 
206 Reputation 36 Total posts
denis

denis

1/12/2011 1:40:57 PM
It doesn't have to do anything with the installation package. Somehow your IIS is still running the MonoX app pool under .NET 2.0.
Let's try this: install MonoX under the same app pool, but don't switch the web.config files. Does it work in that case?
This content has not been rated yet. 
7207 Reputation 956 Total posts
yousaid

yousaid

1/13/2011 5:39:01 PM
You are correct. It is either my box or user error.
It is most likely user error. I say this becuase I tried on another box this time running WinXp and I am getting same behavior. (All I want to do is get the sample to run. No custom project)

So here is what I am doing.
Step 1.
Download the new build.
Step 2.
Unzip to a folder.
Step 3.
Use Sql Mgt console, create a DB, and grant all permission to aspnet account. (Network services)
Step 6.
Open the web.config in the download (now in the folder) and update the conectionstrings to use my DB.
Step 7.
Start VS 2010 Ultimate, then choose, file, Open website and open the MonoX (the downLoad)
(also have tried opening it as project by copying the contents of Samples folder and updating the webconfig.
Step 8
Rebuild the application. Then try to run Defualt.aspx from the Installer folder.
At this step, Installer starts ok. Goes through the staeps and puts a green check mark on the permissions verification.
(also tried excluding the precompilation file that is included)
Step 9.
Click Next, then, I get error that says, "file Not found....." the file it is looking for is a License file.
NOTE: When I install the older versions, at this step, I get a Checkbox to accept the terms.
But for some reason, I never get the check box and installation fails. I guess, becuase the license was not accepted.
Any ideas why this file (license file never gets called? I can clearly see the file in the folder.
cheers,
yousaid
This content has not been rated yet. 
206 Reputation 36 Total posts
denis

denis

1/13/2011 9:34:33 PM
Hi,
steps from 6 onward are wrong. You shouldn't manuall modify the web.config or recompile MonoX during the installation. You don't have to use VS at all during this process. So...
6. open a new site or virtual folder in the IIS manager that points to the folder where you unziped MonoX files. If you are using the virtual folder, create the new application on it. Make sure that the application pool under which MonoX will run is using the NetworkService acount (if you want to use that particular account, IIS 7 is using special ApplicationPoolIdentity)
7. assign write permissions to NetworkService account on the MonoX installation folder (so it could modify web.config, write logs, etc)
8. open the browser and enter the URL of a site or virtual folder opened in step 6. At this point the installation wizard should start and guide you through the rest of the process.
This content has not been rated yet. 
7207 Reputation 956 Total posts
1 2