MonoX support board

Start the conversation, ask questions and share tips and solutions with fellow developers.

Non-registered users can only browse through our support boards. Please register now if you want to post your questions. It takes a second and it is completely free. Alternatively, you can log in without registration using your credentials at major sites such as Google, Microsoft Live, OpenId, Facebook, LinkedIn or Yahoo.

Registration Issues (Closed) (Mono Support )

Viewed 9514 time(s), 5 post(s) 10/10/2013 11:16:10 PMby baytes
baytes

baytes

10/10/2013 11:16:10 PM
I'm having issues with users registering, once they fill out the registration page and click 'create account' the user is presented with the error page. On the backend i've noticed that the user is by default set to 'IsApproved' = False. I'm assuming that this is where the issue lies. Can someone help me to resolve this issue as it is extremely important that users cannot register. Any help is greatly appreciated.

Thanks!!
This content has not been rated yet. 
95 Reputation 11 Total posts
baytes

baytes

10/10/2013 11:41:41 PM
Also I've narrowed it down to the portal not sending the activation email, its trying to use 'mail.yourdomain.com' which obviously isn't going to work. Where do I change this?

Here is the output of the log:

An error has occured in the application.

This event has been logged and will be addressed by the maintenance department. We appreciate your patience.

An
uexpected error has occured while sending you an activation e-mail.
Your account has been successfully created but you can't login until you
activate it via activation e-mail. To resend your activation e-mail
please go to the Activation e-mail recovery page. If the problem persists, please contact us.
at MonoSoftware.MonoX.ModuleGallery.MembershipEditor.#Jp(Object sender, EventArgs e)
at System.Web.UI.WebControls.LinkButton.RaisePostBackEvent(String eventArgument)
at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

An error has occured while sending you an e-mail. Please try again, if the problem persists, please contact us.
at MonoSoftware.MonoX.Mail.MonoXMailSender.SendMail(MailMessage mailMsg)
at MonoSoftware.Core.Mail.MailSender.SendMail(String toAddress, String title, String htmlContent, String plainContent)
at MonoSoftware.MonoX.ModuleGallery.MembershipEditor.#Jp(Object sender, EventArgs e)

Failure sending mail.
at System.Net.Mail.SmtpClient.Send(MailMessage message)
at MonoSoftware.Core.Mail.MailSender.SendMail(MailMessage mailMsg)

The remote name could not be resolved: 'mail.yourdomain.com'

at System.Net.ServicePoint.GetConnection(PooledStream PooledStream,
Object owner, Boolean async, IPAddress& address, Socket&
abortSocket, Socket& abortSocket6, Int32 timeout)
at System.Net.PooledStream.Activate(Object owningObject, Boolean
async, Int32 timeout, GeneralAsyncDelegate asyncCallback)
at System.Net.PooledStream.Activate(Object owningObject,
GeneralAsyncDelegate asyncCallback)
at System.Net.ConnectionPool.GetConnection(Object owningObject,
GeneralAsyncDelegate asyncCallback, Int32 creationTimeout)
at System.Net.Mail.SmtpConnection.GetConnection(ServicePoint
servicePoint)
at System.Net.Mail.SmtpClient.Send(MailMessage message)
This content has not been rated yet. 
95 Reputation 11 Total posts
baytes

baytes

10/11/2013 2:12:59 AM
Ok, I managed to figure out that this was an issue with the setting in the web.config, I was able to change it from:
[code]
  <mailSettings>
      <smtp deliveryMethod="Network">
        <network host="mail.yourdomain.com" />
      </smtp>
      </smtp>
    </mailSettings>
[/code]
To:
[code]
  <mailSettings>
     <!--<smtp deliveryMethod="Network">
        <network host="mail.yourdomain.com" />
      </smtp>-->
<smtp deliveryMethod="Network" from="xxxxx@gmail.com">
<network host="smtp.gmail.com" userName="xxxxx@gmail.com"
password="xxxxx" port="587" enableSsl="true"
defaultCredentials="false" />
      </smtp>
    </mailSettings>
[/code]

and also change the 'EnableSmtpSSL' value to true (see below):
[code]
<!-- flag if SSL is enabled while sending an e-mail portal wide -->
    <add key="EnableSmtpSSL" value="True" />
[/code]

this works locally with no issues however on my production server i'm still getting an error.
Here is the error:
[log start]
The Zone of the assembly that failed was:
MyComputer
2013-10-10 22:02:56,689 [40] ERROR MonoX [69.123.21.32] - An error has occured while sending you an e-mail. Please try again, if the problem persists, please contact us.
   at MonoSoftware.MonoX.Mail.MonoXMailSender.SendMail(MailMessage mailMsg)
   at MonoSoftware.Core.Mail.MailSender.SendMail(String toAddress, String title, String htmlContent, String plainContent)
   at MonoSoftware.MonoX.ModuleGallery.MembershipEditor.#Jp(Object sender, EventArgs e)

The SMTP server requires a secure connection or the client was not authenticated. The server response was: 5.5.1 Authentication Required. Learn more at
   at System.Net.Mail.MailCommand.CheckResponse(SmtpStatusCode statusCode, String response)
   at System.Net.Mail.MailCommand.Send(SmtpConnection conn, Byte[] command, String from)
   at System.Net.Mail.SmtpTransport.SendMail(MailAddress sender, MailAddressCollection recipients, String deliveryNotify, SmtpFailedRecipientException& exception)
   at System.Net.Mail.SmtpClient.Send(MailMessage message)
   at MonoSoftware.Core.Mail.MailSender.SendMail(MailMessage mailMsg)

2013-10-10 22:02:56,689 [40] ERROR MonoX [69.123.21.32] - Error
System.ApplicationException: An uexpected error has occured while sending you an activation e-mail. Your account has been successfully created but you can't login until you activate it via activation e-mail. To resend your activation e-mail please go to the <a href="/Membership/ActivationEmailRecovery.aspx">Activation e-mail recovery</a> page. If the problem persists, please contact us. ---> System.ApplicationException: An error has occured while sending you an e-mail. Please try again, if the problem persists, please contact us. ---> System.Net.Mail.SmtpException: The SMTP server requires a secure connection or the client was not authenticated. The server response was: 5.5.1 Authentication Required. Learn more at
   at System.Net.Mail.MailCommand.CheckResponse(SmtpStatusCode statusCode, String response)
   at System.Net.Mail.MailCommand.Send(SmtpConnection conn, Byte[] command, String from)
   at System.Net.Mail.SmtpTransport.SendMail(MailAddress sender, MailAddressCollection recipients, String deliveryNotify, SmtpFailedRecipientException& exception)
   at System.Net.Mail.SmtpClient.Send(MailMessage message)
   at MonoSoftware.Core.Mail.MailSender.SendMail(MailMessage mailMsg)
   --- End of inner exception stack trace ---
   at MonoSoftware.MonoX.Mail.MonoXMailSender.SendMail(MailMessage mailMsg)
   at MonoSoftware.Core.Mail.MailSender.SendMail(String toAddress, String title, String htmlContent, String plainContent)
   at MonoSoftware.MonoX.ModuleGallery.MembershipEditor.#Jp(Object sender, EventArgs e)
   --- End of inner exception stack trace ---
   at MonoSoftware.MonoX.ModuleGallery.MembershipEditor.#Jp(Object sender, EventArgs e)
   at System.Web.UI.WebControls.LinkButton.RaisePostBackEvent(String eventArgument)
   at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
[/log end]


Any help is GREATLY appreciated.
This content has not been rated yet. 
95 Reputation 11 Total posts
khorvat

khorvat

10/12/2013 6:59:47 AM
Hi,

  sorry for a delay, this is definitely a GMail setting issue, I'm not sure if this is the right port because you are using ssl, can you please check.

Thanks
This content has not been rated yet. 
15993 Reputation 2214 Total posts
baytes

baytes

10/12/2013 2:04:01 PM
Thank you for your reply, I've solved the issue you were right it was something to do with gmail (although i'm not exactly sure what the issue was) however I switched from using gmail to another provider, and that solved the issue. Thanks for your quick response.
This content has not been rated yet. 
95 Reputation 11 Total posts