MonoX support board

Start the conversation, ask questions and share tips and solutions with fellow developers.

Non-registered users can only browse through our support boards. Please register now if you want to post your questions. It takes a second and it is completely free. Alternatively, you can log in without registration using your credentials at major sites such as Google, Microsoft Live, OpenId, Facebook, LinkedIn or Yahoo.

Problem in running exe file on redhat linux with mono  (Mono Support )

Viewed 7803 time(s), 3 post(s) 2/28/2012 6:05:32 AMby sanjay1974
sanjay1974

sanjay1974

2/28/2012 6:05:32 AM
Hi,


I am trying to run an exe file with mono on redhat linux. The exe file has been generated using the following command:

ironahk --out example.exe Example.ahk

IronAHK is the linux counterpart of autohotkey.

The exe file tries to draw a graphics window and it is running absolutely fine on windows XP.
With mono, it is giving the following error. Kindly help.

Thanks and Best Regards,

Sanjay


--> mono example.exe


Unhandled Exception: System.TypeInitializationException: An exception
was thrown by the type initializer for Script --->
System.TypeInitializationException: An exception was thrown by the type
initializer for System.Windows.Forms.XplatUI --->
System.TypeInitializationException: An exception was thrown by the type
initializer for System.Drawing.GDIPlus --->
System.DllNotFoundException: gdiplus.dll

at (wrapper managed-to-native) System.Drawing.GDIPlus:GdiplusStartup
(ulong&,System.Drawing.GdiplusStartupInput&,System
.Drawing.GdiplusStartupOutput&)

at System.Drawing.GDIPlus..cctor () [0x00000] in <filename unknown>:0

--- End of inner exception stack trace ---

at System.Drawing.Graphics.FromHdcInternal (IntPtr hdc) [0x00000] in <filename unknown>:0

at System.Windows.Forms.XplatUIX11.SetDisplay (IntPtr display_handle) [0x00000] in <filename unknown>:0

at System.Windows.Forms.XplatUIX11..ctor () [0x00000] in <filename unknown>:0

at System.Windows.Forms.XplatUIX11.GetInstance () [0x00000] in <filename unknown>:0

at System.Windows.Forms.XplatUI..cctor () [0x00000] in <filename unknown>:0

--- End of inner exception stack trace ---

at System.Windows.Forms.Application.EnableVisualStyle s () [0x00000] in <filename unknown>:0

at Script..cctor () [0x00000] in <filename unknown>:0

--- End of inner exception stack trace ---

at Program.Main () [0x00000] in <filename unknown>:0

Exit 1












This content has not been rated yet. 
15 Reputation 1 Total posts
khorvat

khorvat

2/28/2012 7:00:48 AM
Hi,

I'm not sure that you have posted your question to the right forum, this forum is support for MonoX CMS users and I suppose you were looking for the support for the Mono framework (Take a look here or here).

If this isn't a case please provide us with more information.

Regards
This content has not been rated yet. 
15993 Reputation 2214 Total posts
shawndg

shawndg

2/28/2012 12:47:16 PM
Hi,

I think this is not the right forum..

However, I do think your problem is this..
http://www.mono-project.com/Gui_Toolkits

Have you used custom controls in your app ?
If so, then this may be the problem.

By default the windows forms portion of Mono only supports standard MS winform controls..
Any other third party control is not supported... May work but not supported.
This content has not been rated yet. 
1871 Reputation 252 Total posts