MonoX support board

Start the conversation, ask questions and share tips and solutions with fellow developers.

Non-registered users can only browse through our support boards. Please register now if you want to post your questions. It takes a second and it is completely free. Alternatively, you can log in without registration using your credentials at major sites such as Google, Microsoft Live, OpenId, Facebook, LinkedIn or Yahoo.

Error: 40 - Could not open a connection to SQL server  (Mono Support )

Viewed 12734 time(s), 4 post(s) 1/31/2014 5:40:12 AMby Samtg
Samtg

Samtg

1/31/2014 5:40:12 AM
Hi,
     I got the following error code while trying to install Monox with the Web Platform Installer:  Error: 40 - Could not open a connection to SQL server.
     I am trying to install Monox on another server, or with another host (godaddy), and was trying to figure out if there is a way to do this, and if I got to change where the Database server is located (besides what it might be).

Thank you for your help.
  
This content has not been rated yet. 
440 Reputation 38 Total posts
dbogdan

dbogdan

1/31/2014 7:41:58 AM
Hi Samtg,

The cause of the specified error could be in a numerous things. In order to successfully resolve that problem, please check up the following things:
1. SQL server instance is running
2. Be aware of the firewall settings (SQL Server port must not be blocked)
3. Enable TCP/IP Protocol in order to allow remote connection
Basically remote connection to the server needs to be allowed. Please refer to this helpful article: http://blogs.msdn.com/b/walzenbach/archive/2010/04/14/how-to-enable-remote-connections-in-sql-server-2008.aspx

If your problem still occurs, we will need more info, like:
1. Are you using a shared hosting?
2. Please take a look GoDaddy connection strings
3. Can you provide us with yours connection string, and maybe detailed error log?

Regards,
Darjan
This content has not been rated yet. 
231 Reputation 38 Total posts
Samtg

Samtg

2/3/2014 7:12:55 PM
Thanks, that worked.  Now when I go to the webpage, this comes up:
403 Forbidden

You do not have permission to access this document.

I am using WebMatrix 3 to try to get the site running, with an initial setup, is there a way to get rid of this error?


Thanks.

This content has not been rated yet. 
440 Reputation 38 Total posts
dbogdan

dbogdan

2/4/2014 3:24:12 PM
Hi Samtg.

Probably you have problems with a security restrictions.
Problem could occur because of permissions settings in:
1. Aspnet server configuration files
2. Folder of that particular webpage file
3. Maybe even with that specific 

First of all try with a permission settings of that folder: Go to the Properties -> Security Tab
Inside Group or user names should be "NETWORK SERVICE" user, if that user is not there, please add it with a read permission.

If your problem persists after security configuration, please send us Logs in order to fully understand given problem.

Regards,
Darjan
This content has not been rated yet. 
231 Reputation 38 Total posts