MonoX support board

Start the conversation, ask questions and share tips and solutions with fellow developers.

Non-registered users can only browse through our support boards. Please register now if you want to post your questions. It takes a second and it is completely free. Alternatively, you can log in without registration using your credentials at major sites such as Google, Microsoft Live, OpenId, Facebook, LinkedIn or Yahoo.

OAuth Facebook login error: Brickred.SocialAuth.NET.Core.DataParsingException  (Mono Support )

Viewed 7193 time(s), 10 post(s) 5/19/2016 9:51:27 PMby DavidVeksler
DavidVeksler

DavidVeksler

5/19/2016 9:51:48 PM
See attached error message.  Here is the log:

2016-05-19 17:23:37,065 [1] INFO  MonoX [BaseHttpApplication] - Application Start
2016-05-19 17:23:45,755 [16] INFO  OAuth2_0server [(null)] - OAuth2.0 Authorization Flow begins for FACEBOOK...
2016-05-19 17:23:46,265 [8] INFO  OAuth2_0server [(null)] - User successfully logged in and returned with Authorization code
2016-05-19 17:23:46,387 [8] INFO  OAuth2_0server [(null)] - Access Token successfully received
2016-05-19 17:23:46,389 [8] INFO  OAuth2_0server [(null)] - OAuth2.0 server side Authorization flow ends ..
2016-05-19 17:23:46,449 [8] INFO  OAuth2_0server [(null)] - Successfully executed  https://graph.facebook.com/me using GET
2016-05-19 17:44:15,167 [29] INFO  MonoX [BaseHttpApplication] - Application End
This content has not been rated yet. 
32 Reputation 4 Total posts
DavidVeksler

DavidVeksler

5/20/2016 12:41:44 AM
The SocialAuth version used by MonoX is 2.1, but the latest is 2.4: https://www.nuget.org/packages/SocialAuth.NET
Is it possible that you just need to update the version of SocialAuth used?    
Alternatively, you can specify an older version of the Facebook API, as the AdditionalScopes scopes in MonoX web.config are invalid in the current Facebook API.

Is it possible that you just need to update it?  I can't do it myself because I don't have the MonoX source, and log4net is a common dependency with a public key token change.
This content has not been rated yet. 
32 Reputation 4 Total posts
mzilic

mzilic

5/20/2016 3:18:59 PM
Can you check in your Facebook app settings which version of the API you are using and let us know? Also which version of MonoX are you using as the latest MonoX is using 2.4 version?

Regards,
Mario
This content has not been rated yet. 
2218 Reputation 300 Total posts
DavidVeksler

DavidVeksler

5/20/2016 3:30:02 PM
Hi,

I downloaded MonoX from this website two days ago: "MonoX Portal Engine v5.1.40.5152 created on 7/6/2015"
Using Facebook API 2.5 - I created this Facebook app last month.
This content has not been rated yet. 
32 Reputation 4 Total posts
DavidVeksler

DavidVeksler

5/20/2016 3:38:26 PM
You can try it at http://alumni.fee.org/


This content has not been rated yet. 
32 Reputation 4 Total posts
mzilic

mzilic

5/20/2016 3:44:19 PM
Hi,

We are working on it. There seem to have been changes in FB API and SocialAuth.net doesn't seem to have been updated to handle the latest API changes. We will let you know when a fix is available for this.

Regards,
Mario
This content has not been rated yet. 
2218 Reputation 300 Total posts
dbogdan

dbogdan

5/24/2016 11:06:58 AM
Hi David,

Please could you replace your current SocialAuth-net.dll with the attached one. We have implemented needed changes due to changes in the FacebookAPI v2.4+. It should work, however if you find any issues please get back to us.

Regards,
Darjan
This content has not been rated yet. 
231 Reputation 38 Total posts
Zoomicon

Zoomicon

6/3/2016 4:09:41 PM

I've seen similar issue with http://trafilm.net (have removed social login for now there) that is under development.

I had cloned that from http://social.clipflair.net where social login still works fine

is it that newer facebook apps I create use the newer facebook API and olders use previous one? Can I choose FB API version somewhere at my app settings on Facebook dev site to tell it to user older API? Or should I just try to use the newer DLL? Note that I use MonoX v4.9.40.4845 [12/25/2013], DB v4.7.3842

This content has not been rated yet. 
2793 Reputation 345 Total posts
Zoomicon

Zoomicon

6/3/2016 4:28:19 PM
Tried to use that DLL and get internal server error, guess it's for newer MonoX only. How can one get a fixed one for older MonoX?
This content has not been rated yet. 
2793 Reputation 345 Total posts
slaven

slaven

6/6/2016 3:11:24 PM
Hi Zoomicon,

New Facebook apps can use only newer Facebook API versions and older can use older API versions.
You can check which is the oldest Facebook API version for your app in app dashboard: https://developers.facebook.com

Can you please paste error messages from log here ?

Best regards,
Slaven
This content has not been rated yet. 
144 Reputation 22 Total posts