MonoX support board

Start the conversation, ask questions and share tips and solutions with fellow developers.

Non-registered users can only browse through our support boards. Please register now if you want to post your questions. It takes a second and it is completely free. Alternatively, you can log in without registration using your credentials at major sites such as Google, Microsoft Live, OpenId, Facebook, LinkedIn or Yahoo.

Issue when .NET 4.5 missing from machine  (Mono Support )

Viewed 24105 time(s), 5 post(s) 4/9/2013 8:50:19 AMby Zoomicon

Related topics

Zoomicon

Zoomicon

4/9/2013 8:50:19 AM
I was installing latest MonoX on our designer's machine and although it run fine, when I tried to upgrade our current database to it and run it I got:

Could not load type 'System.Runtime.CompilerServices.ExtensionAttribute' from assembly 'mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089'

I searched for that and found:
http://stackoverflow.com/questions/13748055/could-not-load-type-system-runtime-compilerservices-extensionattribute-from-as
which says that the issue is cause because an attribute has changed assembly or namespace or something like that from .NET 4.0 to .NET 4.5. This shouldn't be a problem because of some type mapping being set in the system, but if you've used ILMerge with some wrong parameters then it can cause this error when machine doesn't have .NET 4.5 but only 4.0 and tries to load the merged assembly

from that the following are mentioned:
http://marcgravell.blogspot.co.nz/2012/09/iterator-blocks-missing-methods-and-net.html
https://connect.microsoft.com/VisualStudio/feedback/details/726702/moving-system-runtime-compilerservices-extensionattribute-to-mscorlib-breaks-structuremap-scans-of-namespaces-containing-extensionmethods-and-possibly-other-ioc-scenarios
http://www.mattwrock.com/post/2012/02/29/What-you-should-know-about-running-ILMerge-on-Net-45-Beta-assemblies-targeting-Net-40.aspx

so I installed .NET 4.5 from:
http://www.microsoft.com/visualstudio/eng/downloads#d-net-45
rebooted the Win7 machine as prompted

and that issue seems to be fixed now, but I'm getting other error (please see separate post)
This content has not been rated yet. 
2793 Reputation 345 Total posts
khorvat

khorvat

4/9/2013 9:10:37 AM
Can you let me know was this a MonoX nightly build or latest release ? We should have fixed the nightly build, basically Newtonsoft.Json.dll for .NET 3.5 or older has this issue so we upgraded to the latest version to get this working.

Regards
This content has not been rated yet. 
15993 Reputation 2214 Total posts
Zoomicon

Zoomicon

4/9/2013 9:49:45 AM
yes it was the latest nightly build (downloaded and installed it yesterday)
This content has not been rated yet. 
2793 Reputation 345 Total posts
khorvat

khorvat

4/9/2013 10:00:37 AM
Ok, thanks we will review the build and have QA to check this.
This content has not been rated yet. 
15993 Reputation 2214 Total posts
khorvat

khorvat

6/14/2013 1:48:02 PM
We have fixed everything around this issue, also new MonoX v4.8 version has been pushed to our download section, although it is still unofficial you can download it.

Regards
This content has not been rated yet. 
15993 Reputation 2214 Total posts