MonoX support board

Start the conversation, ask questions and share tips and solutions with fellow developers.

Non-registered users can only browse through our support boards. Please register now if you want to post your questions. It takes a second and it is completely free. Alternatively, you can log in without registration using your credentials at major sites such as Google, Microsoft Live, OpenId, Facebook, LinkedIn or Yahoo.

Error in Login using Facebook Account  (Mono Support )

Viewed 14429 time(s), 16 post(s) 3/28/2013 3:59:17 AMby sam0864
sam0864

sam0864

3/28/2013 4:01:13 AM
I created Facebook App and updated web.config file with App ID and secret Key.

After I login using my facebook login ID/password, I get page not found error with this URL
http://mydomain.com/socialauth/validate.sauth?code=AQDN6epqiJm0QMvNBvtm4EJePc_TqEw-kg3kWdm-glkHbdGH5pJ_EuahorgVHcY0hGXf9ebsHlLNM72yTInvauPr2Z8-ydz9nBjzNAq5S-3K7QKmtpbgCY-xUcW1mPq50GQUfFtgsBE3D-AjswORwqjr25gx3N75rl913eLaY_26qLxkjrG3rfJBC4zA4NKOxzXxoAwbudx5Z6g83GSz1IhV#_=_

Is there any parameter has to be updated for Login using Facebook account to work?
I have 4.7.4373
Thank you
This content has not been rated yet. 
656 Reputation 79 Total posts
mzilic

mzilic

3/28/2013 11:34:55 AM
Hello,

I have a couple of questions:
Have you configured the App Domains and Site URL in the Facebook app settings?
Are you using Forms Authentication?
Are you using the default social-auth binaries which came with MonoX?

Regards,
Mario
This content has not been rated yet. 
2218 Reputation 300 Total posts
sam0864

sam0864

3/28/2013 1:04:50 PM
Yes, I entered the app domain and site URL as mono.mydomain.com (my testing URL )
I am using the same code from the nighty build
This content has not been rated yet. 
656 Reputation 79 Total posts
mzilic

mzilic

3/28/2013 8:28:50 PM
Please ensure that in your web.config you have this handler registered:
<add name="socialAuth.NET" verb="*" path="*.sauth" type="Brickred.SocialAuth.NET.Core.CallbackHandler" />
Regards,
Mario
This content has not been rated yet. 
2218 Reputation 300 Total posts
sam0864

sam0864

3/29/2013 2:41:33 PM
yes, the handler is already there in the web.config
This content has not been rated yet. 
656 Reputation 79 Total posts
khorvat

khorvat

4/2/2013 9:27:43 AM
Can you also confirm that handler is in both places for IIS 6 & 7.x ?

Thanks
This content has not been rated yet. 
15993 Reputation 2214 Total posts
sam0864

sam0864

4/2/2013 3:14:32 PM
I have the following
under httpHandlers
<add verb="*" path="*.sauth" type="Brickred.SocialAuth.NET.Core.CallbackHandler" />

and under handlers
<add name="socialAuth.NET" verb="*" path="*.sauth" type="Brickred.SocialAuth.NET.Core.CallbackHandler" />

I am running windows 2003 web server
This content has not been rated yet. 
656 Reputation 79 Total posts
sam0864

sam0864

5/30/2013 3:46:29 AM
UPDATE
It worked in IIS 7 (windows 7) but it did not work in IIS 6.0 (windows 2003 server)

I used the same setting/configuration and build in both

This content has not been rated yet. 
656 Reputation 79 Total posts
sam0864

sam0864

5/31/2013 4:38:35 AM
Any help to make it working on IIS 6.0
Does it require additional or different configuration??
This content has not been rated yet. 
656 Reputation 79 Total posts
khorvat

khorvat

5/31/2013 10:05:52 AM
Please check the mime types for that handler in the IIS 6 configuration.
This content has not been rated yet. 
15993 Reputation 2214 Total posts
1 2