MonoX support board

Start the conversation, ask questions and share tips and solutions with fellow developers.

Non-registered users can only browse through our support boards. Please register now if you want to post your questions. It takes a second and it is completely free. Alternatively, you can log in without registration using your credentials at major sites such as Google, Microsoft Live, OpenId, Facebook, LinkedIn or Yahoo.

Internal Server Error (Closed) (Mono Support )

Viewed 53658 time(s), 3 post(s) 7/22/2011 2:51:54 AMby kip

Related topics



7/22/2011 2:51:54 AM

I am attempting to create a custom project based on MonoX 4. I have my dev environment working properly, but when I attempt to access the site through IIS I get the following:

Server ErrorInternet Information Services 7.0
Error Summary
HTTP Error 500.19 - Internal Server Error
The requested page cannot be accessed because the related configuration data for the page is invalid. Detailed Error Information
Module IIS Web Core
Notification BeginRequest
Handler Not yet determined
Error Code 0x80070032
Config Error The configuration section 'system.web.extensions' cannot be read because it is missing a section declaration
Config File \\?\C:\inetpub\wwwroot\HardQnA\web.config
Requested URL
Physical Path C:\inetpub\wwwroot\HardQnA
Logon Method Not yet determined
Logon User Not yet determined
Config Source
485: </system.web>
486: <system.web.extensions>
487: <scripting>
Links and More InformationThis error occurs when there is a problem reading the configuration file for the Web server or Web application. In some cases, the event logs may contain more information about what caused this error.
View more information »

I have tried to resolve the problem by using a working web.config file from another setup on my Intranet but get the same error. I have made the appropriate changes to the web.config as described in the blog post about creating a custom project based on MonoX.

My appologies ahead of time if this is trivial. Any help would be appreciated.
This content has not been rated yet. 
10 Reputation 2 Total posts


7/22/2011 5:29:30 AM

As it turns out, this was trivial. When I installed to IIS originally, I used the Web Platform Installer. It created an Application Pool for the installation and set the target framework to .NET 4. When I set up the dev system, I installed from the source package and neglected to properly set the framework version for the application pool. The default was .NET 2.x. After making the change from v2.x to v4 in IIS Manager, the lights came on.

For anyone who comes across this post with the same issue, do the following:

1. Start the IIS Manager
2. From the Connections Pane on the left, expand the server node and then click Application Pools..
3. In the right pane (Application Pools) double-click on the application pool to which you have the application assigned.
4. From the .NET Framework Version dropdown, select .NET Framework v4.

I know this step was documented prior to this post. My appologies and thanks for a great CMS.
This content has not been rated yet. 
10 Reputation 2 Total posts


7/22/2011 6:52:34 AM

yes this can be a common mistake, but it is solved in a matter of minutes, as you did so :). Thanks for a few nice words.

This content has not been rated yet. 
15993 Reputation 2214 Total posts