MonoX support board

Start the conversation, ask questions and share tips and solutions with fellow developers.

Non-registered users can only browse through our support boards. Please register now if you want to post your questions. It takes a second and it is completely free. Alternatively, you can log in without registration using your credentials at major sites such as Google, Microsoft Live, OpenId, Facebook, LinkedIn or Yahoo.

monox installation problem  (Mono Support )

Viewed 4774 time(s), 4 post(s) 10/30/2013 11:58:51 PMby EdiSasongko
EdiSasongko

EdiSasongko

10/31/2013 2:20:33 AM
Hello, 

I have problem while installing monox.
Installation was never  completed, it had just render InstallComplete.aspx but it seems to never end although the tables are successfull created.

Please take a look the attachments, I am going crazy about this :(
Can you please assist me how to solve it ?

Thank you
This content has not been rated yet. 
41 Reputation 3 Total posts
khorvat

khorvat

10/31/2013 7:25:05 AM
Hi,

please check few of the following issues:

- Check if you have set the IIS application pool to integrated mode
- Check Handler Mappings in IIS Manager, there should be following mappings:
Request Path: *.axd 
Executable: C:\Windows\Microsoft.NET\Framework\v4.0.30319\aspnet_isapi.dll 
Name: AXD-ISAPI-4.0_32bit 
Request Path: *.axd 
Executable: C:\Windows\Microsoft.NET\Framework64\v4.0.30319\aspnet_isapi.dll 
Name: AXD-ISAPI-4.0_64bit
- Is there any other ASP.NET Web site running properly on that box ?

Regards
This content has not been rated yet. 
15993 Reputation 2214 Total posts
EdiSasongko

EdiSasongko

11/7/2013 7:01:19 AM
Hello,

Thank you for your response and sorry for my late reply. 
I've tried your way to add a handler mapping in IIS  Manager but it still returned same error. 

I look at the ScriptManager url's error, so I ended up moving this virtual directory to the root.
It means moved from http://10.X.X.X/VirtualDirectory to http://10.X.X.X without virtual directory.
And now its working.

Thank you 
This content has not been rated yet. 
41 Reputation 3 Total posts
khorvat

khorvat

11/7/2013 1:37:00 PM
I'm glad to hear that you have fixed your issue, in most cases this should work without any issues. Did you found out why this isn't working in virtual directory ?

Regards
This content has not been rated yet. 
15993 Reputation 2214 Total posts