MonoX support board

Start the conversation, ask questions and share tips and solutions with fellow developers.

Non-registered users can only browse through our support boards. Please register now if you want to post your questions. It takes a second and it is completely free. Alternatively, you can log in without registration using your credentials at major sites such as Google, Microsoft Live, OpenId, Facebook, LinkedIn or Yahoo.

Installer can't see Network Service OR IIS App Pool has write permissions to web.config  (Mono Support )

Viewed 11888 time(s), 5 post(s) 1/3/2013 10:08:51 PMby zach
zach

zach

1/3/2013 10:08:51 PM
My install is failing on the first step when it checks permissions. I granted the app pool permissions to the entire install directory and it still doesnt show it can write to the web.config. Additionally, I switched the app pool to Network Service and I'm getting the same error no matter what. I've also tried to manually give that one specific file write permissions, give the service ownership of the file, and alas nothing is working. All folder checks in those process shows it has permissions just the web.config file is giving me problems.
This content has not been rated yet. 
65 Reputation 8 Total posts
khorvat

khorvat

1/3/2013 10:23:41 PM
Hi,

can you please provide us with few screenshots, we need IIS basic and advance settings screenshot, and MonoX installer first screen screenshot.

Thanks
This content has not been rated yet. 
15993 Reputation 2214 Total posts
zach

zach

1/4/2013 9:58:40 PM
Here you go. Let me know what else I can provide...
This content has not been rated yet. 
65 Reputation 8 Total posts
denis

denis

1/7/2013 11:23:24 AM
If the app pool is switched to Network Service and restarted (as you say, I cannot see that on the screenshots you attached), this should work. It is very strange to have only one failed check, as the logs subfolder usually shows the same. Did you try to run the install regardless of the indicator? Installer needs the write privileges to modify the database connection string and the "installation done" flag in the web.config, and both changes can also be performed manually.
This content has not been rated yet. 
7207 Reputation 956 Total posts
zach

zach

1/8/2013 5:57:27 PM
Well it seems to have worked, I am browsing the site now... Thanks a lot...



Zach
This content has not been rated yet. 
65 Reputation 8 Total posts