MonoX support board

Start the conversation, ask questions and share tips and solutions with fellow developers.

Non-registered users can only browse through our support boards. Please register now if you want to post your questions. It takes a second and it is completely free. Alternatively, you can log in without registration using your credentials at major sites such as Google, Microsoft Live, OpenId, Facebook, LinkedIn or Yahoo.

accessing SN messaging center properties from Messages page throws exception (Closed) (Mono Support )

Viewed 45824 time(s), 22 post(s) 9/14/2011 7:58:04 PMby rovvy
rovvy

rovvy

9/16/2011 3:12:30 PM
done. let me know if you got the message.
after you log it, you will see the 'Messages' tab in the menu
This content has not been rated yet. 
152 Reputation 21 Total posts
khorvat

khorvat

9/16/2011 8:50:00 PM
Hi,

I have take a look at the issue you are having and I have found a bug in the personalization functionality deep down in the personalization core. We are fixing this issue as we speak and it will be included in the next release. To solve your issue you will need to reach out to the database and delete the personalization blob record for the Messages page. To do so follow the steps below:

1. Find the PathId of the /MonoX/Pages/SocialNetworking/Messages.aspx page in the aspnet_Paths table
2. Delete the record with the PathId that you have found in the previous step from the aspnet_PersonalizationAllUsers table
3. Now try to access the Message center Web part properties

Let me know if this has solved the issue.

Regards
This content has not been rated yet. 
15993 Reputation 2214 Total posts
rovvy

rovvy

9/17/2011 9:26:49 AM
Will try to follow the steps suggested and let you know how it goes.
This content has not been rated yet. 
152 Reputation 21 Total posts
rovvy

rovvy

9/17/2011 10:47:46 AM
Tried the approch and deleted the record from aspnet_PersonalizationAllUser table, but the stack trace is still there.

This content has not been rated yet. 
152 Reputation 21 Total posts
khorvat

khorvat

9/17/2011 3:03:36 PM
Hi,

I'll try to check if anything else should be causing this issue in the SVN, but generally it should work if you have deleted the entry from the DB. Can you please tell me what is the version of the MonoX you are using ? 

Our options at this point are:
1. I'll try to find if there were any other bugs that can cause this issue (I'll let you know what I have found in Monday)
2. I can try to send you a patch if we find the bug
3. You can wait a few days we should release a new version of MonoX (it is in a QA faze) and you can upgrade your installation (Maybe the best solution as you will get many new features that new version will bring)

Let me know what do you want us to do ?

Regards
This content has not been rated yet. 
15993 Reputation 2214 Total posts
rovvy

rovvy

9/19/2011 6:53:14 AM
Our monox version is v4.1.2742.40. We have just starting customizing monox for our needs,
so this is not a stopping issue for us.

However it would be nice to have it fixed.
I think the best will be to go with the 3rd option. However I have a few questions regarding this:

1. will we get the source code version for the new release as well (being that we have source code license for the current version)
2. what features/fixes will be included in the new release?
3. will the new release be applied as a patch to the current one, needs new installation or ?

Thanks,
R
This content has not been rated yet. 
152 Reputation 21 Total posts
khorvat

khorvat

9/19/2011 7:55:39 AM
Hi,

I'm searching for the solution at the moment, if I find the issue I'll try to create a patch for you.

1. If you have a licensed source code you will have the download available in the download section (In the future please post the issues in your Priority support forum we will address them faster). 

2. Here is the unofficial change log
Changelog for MonoX 4.5.2915 (released on 2011-10-01):
 
New features:
 
MonoX mobile: a complete set of new mobile Web parts and pages based on the jQuery mobile framework
Full support for the WYSIWYG editor mode - page style is reflected to all elements in the HTML editor
Totally redesigned Web part catalog, introducing performance improvements and support for drag-and-drop in all major browsers
Enhancements of the Web part zones, using the "tableless" Web part zone as the default option to optimize the HTML code rendered by MonoX
 
Bug fixes:
 
Fixed AutoEventWireup infrastructure
Fixed revisioning/change approval feature
Fixed localization in file upload parts


3. I'll provide you with the patch as an assembly and as a code patch that you can apply to a source code.

Regards
This content has not been rated yet. 
15993 Reputation 2214 Total posts
khorvat

khorvat

9/19/2011 8:15:02 AM
Hi,

I think this may be causing the error, you need to go to the /MonoX/ModuleGallery/SocialNetworking/Messaging/MessageCenter.cs and find the line that looks like this:
[WebBrowsable(true), Personalizable(true), WebEditor(typeof(PagesEditorPart))]

You need to remove the PageEditorPart so line should look like this:
[WebBrowsable(true), Personalizable(true)]

I'm not sending you the assembly patch because you have a source code and you need to build the MessageCenter your self.

Let me know if this has solved the issue ?

Regards
This content has not been rated yet. 
15993 Reputation 2214 Total posts
rovvy

rovvy

9/19/2011 8:58:46 AM
Made the change, rebuild, but the exception is still thrown.
This content has not been rated yet. 
152 Reputation 21 Total posts
khorvat

khorvat

9/19/2011 10:26:36 AM
Hi,

I was referring to this property and it settings:

[WebBrowsable(true), Personalizable(true), WebEditor(typeof(PagesEditorPart))]
[WebDescription("File view page URL")]
[WebDisplayName("File view page URL")]
public string ViewFilePageUrl
{
    get { return messageDetails.ViewFilePageUrl; }
    set
    {
        messageDetails.ViewFilePageUrl = value;
        messageCreate.ViewFilePageUrl = value;
    }
}

Changed to 
[WebBrowsable(true), Personalizable(true)]
[WebDescription("File view page URL")]
[WebDisplayName("File view page URL")]
public string ViewFilePageUrl
{
    get { return messageDetails.ViewFilePageUrl; }
    set
    {
        messageDetails.ViewFilePageUrl = value;
        messageCreate.ViewFilePageUrl = value;
    }
}

If you did that and that didn't help can you please contact me with direct message and I'll try to organize the private remote session and try to fix this error ?

Regards
This content has not been rated yet. 
15993 Reputation 2214 Total posts
1 2 3