MonoX support board

Start the conversation, ask questions and share tips and solutions with fellow developers.

Non-registered users can only browse through our support boards. Please register now if you want to post your questions. It takes a second and it is completely free. Alternatively, you can log in without registration using your credentials at major sites such as Google, Microsoft Live, OpenId, Facebook, LinkedIn or Yahoo.

User registration, OAuth and install from zip (Closed) (Mono Support )

Viewed 47140 time(s), 27 post(s) 5/28/2014 8:14:01 AMby PsMaster

Related topics

mzilic

mzilic

6/22/2014 4:12:57 PM
Hello,

The errors are still indicating that the mailserver is not accepting the credentials. Are you using IIS SMTP to send e-mails or something different? Have you checked the firewall settings? If you're using IIS SMTP have you checked its settings to see if MonoX based site has access rights to the mailserver?

Regards,
Mario
This content has not been rated yet. 
2218 Reputation 300 Total posts
PsMaster

PsMaster

6/22/2014 8:18:32 PM
I can't manage the IIS since I'm purchasing hosting services and not hosting this myself. All I got was 2 ports for secure and not secure connections and SMTP mail service address.
This content has not been rated yet. 
95 Reputation 13 Total posts
imarusic

imarusic

6/24/2014 8:07:56 AM
Hi,

did you try with some other mail server? If it works then there is a definitely an issue with your current mail server.

Regards.
This content has not been rated yet. 
3016 Reputation 428 Total posts
mzilic

mzilic

6/24/2014 10:46:44 AM
Hello,

Can you also contact your host and check if its a mailserver permission related issue?

Regards,
Mario
This content has not been rated yet. 
2218 Reputation 300 Total posts
PsMaster

PsMaster

6/25/2014 5:33:33 PM
I contacted Arvixe support, they're telling me to use port 25 and localhost as host. Tried both settings (secure true and false on both key="EnableSmtpSSL" and enableSsl="true"), but still get the same error. Now I tried the same stuff with gmail services, both secure and not, on ports 587 (throws the error instantly) and 465(times out)...

Quote from Arvixe support reply: "Have you enabled smtp authentication in your script? Please contact a developer and make sure SMTP authentication is enabled in your script." :)
This content has not been rated yet. 
95 Reputation 13 Total posts
PsMaster

PsMaster

6/26/2014 8:11:50 PM
OK, finally fixed the mail problem!!! The final SMTP config:
<add key="EnableSmtpSSL" value="false" />

<mailSettings>
      <smtp deliveryMethod="Network">
        <network host="mail.somedomain.com" userName="mail@somedomain.com" password="somepass" port="25" />
      </smtp>
    </mailSettings>

Seems removing the "from", "enableSsl" and "defaultCredentials" values fixed the problem.
This content has not been rated yet. 
95 Reputation 13 Total posts
imarusic

imarusic

6/27/2014 8:09:53 AM
Hi,

we are glad that you managed to resolve the issue,

Regards
This content has not been rated yet. 
3016 Reputation 428 Total posts
1 2 3