MonoX support board

Start the conversation, ask questions and share tips and solutions with fellow developers.

Non-registered users can only browse through our support boards. Please register now if you want to post your questions. It takes a second and it is completely free. Alternatively, you can log in without registration using your credentials at major sites such as Google, Microsoft Live, OpenId, Facebook, LinkedIn or Yahoo.

404 page can't be edited visually  (Mono Support )

Viewed 18673 time(s), 6 post(s) 6/2/2014 6:51:08 PMby Zoomicon
Zoomicon

Zoomicon

6/2/2014 6:51:08 PM

one can edit a 404 page only by visiting its URL http://.../ErrorPages/404.aspx

</br>if they visit it by typing some wrong URL, then the popup icon that shows the webpart edit actions shows the icons toolbar for webpart actions, but the edit button there doesn't do something

the reason may be that on the address bar the original URL is shown (not the 404 one) in that case and maybe those edit buttons aren't expecting it

This content has not been rated yet. 
2793 Reputation 345 Total posts
mzilic

mzilic

6/5/2014 9:23:50 AM
Hello,

Have you created a custom 404 page perhaps?

Regards,
Mario
This content has not been rated yet. 
2218 Reputation 300 Total posts
Zoomicon

Zoomicon

6/5/2014 11:46:17 AM

I think we had added it following your instructions at http://www.mono-software.com/Mono/Pages/Discussion/dtopic/-oRV9mC-x0a65KLCAKcl4A/MONOX-doesn-t-seem-to-have-a-404-page/ (following up on a report our designer had done to this forum)

the source is:
</br>
</br><%@ Page
</br>    Language="C#"
</br>    MasterPageFile="/MonoX/MasterPages/Default.master"
</br>    AutoEventWireup="true"    
</br>    Inherits="MonoSoftware.MonoX.BasePage"
</br>    Theme="ClipFlair"
</br>    Title="" %>

<%@ MasterType TypeName="MonoSoftware.MonoX.BaseMasterPage" %>  
</br><%@ Register TagPrefix="MonoX" TagName="Editor" Src="/MonoX/ModuleGallery/MonoXHtmlEditor.ascx" %>
</br><%@ Register Assembly="MonoX" Namespace="MonoSoftware.MonoX" TagPrefix="portal" %>
</br><%@ Import Namespace="MonoSoftware.MonoX.Resources" %>

<asp:Content ID="Content1" ContentPlaceHolderID="cp" runat="server">
</br>    <div class="container-highlighter" style="background-color:#666">
</br>        <div class="container">
</br>            <div class="row-fluid clearfix">
</br>                <div class="span12">
</br>                    <portal:PortalWebPartZoneTableless ID="HighlightBanner" runat="server" Width="100%" ChromeTemplateFile="Standard.htm" HeaderText="HighlightBanner">
</br>                        <ZoneTemplate>
</br>                            <MonoX:Editor runat="server" ID="editor01" Title='<%$ Code: PageResources.Title_TopSection %>' DefaultDocumentTitle='<%$ Code: PageResources.Title_TopSection %>'>
</br>                                <DefaultContent>
</br>                                    <p>Error 404</p>
</br>                                </DefaultContent>
</br>                            </MonoX:Editor>
</br>                        </ZoneTemplate>
</br>                    </portal:PortalWebPartZoneTableless>
</br>                </div>
</br>            </div>
</br>        </div>             
</br>    </div>
</br>    <div class="container">
</br>        <div class="row-fluid">
</br>            <div class="span12">
</br>                <portal:PortalWebPartZone HeaderText="Left part zone" ID="leftWebPartZone" runat="server" Width="100%" ChromeTemplateFile="Standard.htm">
</br>                    <ZoneTemplate>
</br>                        <MonoX:Editor runat="server" ID="editor1" />            
</br>                    </ZoneTemplate>
</br>                </portal:PortalWebPartZone>
</br>            </div>
</br>        </div>
</br>    </div>
</br></asp:Content>

This content has not been rated yet. 
2793 Reputation 345 Total posts
Zoomicon

Zoomicon

6/5/2014 11:46:45 AM
(the </br> is added by your forum here, still has issue with IE11)
This content has not been rated yet. 
2793 Reputation 345 Total posts
Zoomicon

Zoomicon

6/5/2014 11:58:53 AM

the bug seems to be that

- when you navigate to the page directly using its url you can then edit it ok (being logged in as admin).

-  If you navigate to it via the page-not-found mechanism (give some wrong url to take you there), up in the address bar you see the wrong url you had entered (this is by design I guess) and when you move mouse over the text webpart you see that popup icon for webpart actions and clicking it you see the respective popup toolbar, but then you click edit and nothing happens

so the 2nd case doesn't work which isn't obvious to the admin and they may think they can't edit visually the page which is wrong (they can)

This content has not been rated yet. 
2793 Reputation 345 Total posts
dbogdan

dbogdan

6/5/2014 2:39:29 PM
Hi,

As you've described in your first post, problem is with URL which is not actual URL of Error.aspx page.

Our web parts are attached to the Page via PageId, and PageId is strictly connected to the URL of the page.
Because of that, you have problem with editing Error.aspx on different(wrong) URL.

However, we will take this issue(unwanted behavior) into account

Regards,
Darjan Bogdan 
Rated 5.00, 1 vote(s). 
231 Reputation 38 Total posts