MonoX support board

Start the conversation, ask questions and share tips and solutions with fellow developers.

Non-registered users can only browse through our support boards. Please register now if you want to post your questions. It takes a second and it is completely free. Alternatively, you can log in without registration using your credentials at major sites such as Google, Microsoft Live, OpenId, Facebook, LinkedIn or Yahoo.

ActivationEmailRecovery ERROR  (Mono Support )

Viewed 12165 time(s), 11 post(s) 11/7/2016 2:32:36 PMby Hutchful
Hutchful

Hutchful

11/7/2016 2:32:36 PM
Hello,

i have been trying to activate a user for some time now, but the error message keeps appearing. CAPTCH page opens alright for a new activation code to be sent in. Moreover i have made the necessary changes to the mailsettings in webconfig
This content has not been rated yet. 
235 Reputation 34 Total posts
zhuber

zhuber

11/7/2016 2:59:21 PM
Hi Hutchful,

We can't know for certain what exactly is happening without error log of the system.
Please send us log file that is  located in ~\Portal\MonoX\ApplicationData\Logs folder of your MonoX installation folder. If you have FTP or RDP to your server, you can easily access that folder in File Explorer and find desired log file.

Best regards,
Željko
This content has not been rated yet. 
145 Reputation 18 Total posts
Hutchful

Hutchful

11/7/2016 3:15:38 PM
Setup MonoX using azure logfiles are inaccessible
This content has not been rated yet. 
235 Reputation 34 Total posts
zhuber

zhuber

11/8/2016 9:54:43 AM
Hi Hutchful,

here is how you can find out your FTP URL and credentials on azure.

Please see get_profile.png image to find out how to get .PublishSettings file.

When you get .PublishSettings file, please refer to profile_content.png image to and see publishUrl (please note that /site/wwwroot should not be excluded from URL), username and password.

If you successfully connect to FTP, you will be able to get log files from ~\Portal\MonoX\ApplicationData\Logs location. You can send us logs then so we can investigate your problem.

Regards,
Željko.
This content has not been rated yet. 
145 Reputation 18 Total posts
Hutchful

Hutchful

11/8/2016 1:43:20 PM
Thanks. I've successfully accessed logfiles
This content has not been rated yet. 
235 Reputation 34 Total posts
Hutchful

Hutchful

11/8/2016 2:00:34 PM
log files as requested
This content has not been rated yet. 
235 Reputation 34 Total posts
dgostinski

dgostinski

11/9/2016 8:16:04 AM
Hi,

Can you please try setting "Mail from address" on this page /MonoX/Admin/PortalSettings.aspx or directly in web.config, key MailFromAddress.

Regards,
David.
This content has not been rated yet. 
125 Reputation 25 Total posts
Hutchful

Hutchful

11/17/2016 1:52:42 PM
Hi,
 How do I go about it? Do I import the  "MailFromAddress" code from webconfig file and set the  values there? There is no code block fro that in PortalSettings.aspx.

Regards,
Hutchful.
This content has not been rated yet. 
235 Reputation 34 Total posts
dcaklovic

dcaklovic

11/18/2016 8:52:16 AM
Hi Hutchful,

You do not need to make any changes to the PortalSettings.aspx file.

There are two ways to achieve this:
1. Go to the MonoX administration,  navigate to /MonoX/Admin/PortalSettings.aspx and set the MailFromAddress value on that page.
2. Or you can change this value in the web.config, key - MailFromAddress

Regards
Daniel
This content has not been rated yet. 
109 Reputation 20 Total posts
Hutchful

Hutchful

11/21/2016 3:08:06 PM
Hello Daniel,

Tried option 1 above but unable to save, here is error message

<---System.NullReferenceException: Object reference not set to an instance of an object.
at MonoSoftware.MonoX.Admin.PortalSettings.OnSave(CancelEventArgs e)--->

Regards,
Hutchful.
This content has not been rated yet. 
235 Reputation 34 Total posts
1 2