MonoX support board

Start the conversation, ask questions and share tips and solutions with fellow developers.

Non-registered users can only browse through our support boards. Please register now if you want to post your questions. It takes a second and it is completely free. Alternatively, you can log in without registration using your credentials at major sites such as Google, Microsoft Live, OpenId, Facebook, LinkedIn or Yahoo.

help about monox after installation, opened visual studio 2010 (Closed) (Mono Support )

Viewed 8105 time(s), 5 post(s) 5/15/2012 6:15:08 PMby stefstef
stefstef

stefstef

5/15/2012 6:15:08 PM
hi all!
i Have a problem! i have installed monox .. it works and it's reallly good..
i have a big problem!!
when i open the project with visualstudio i can't see the controls, all the controls have errors and i can'ts visualize the layout of my pages correctly.. (error during the visualization of the control ) what can i do?
what i have to configure?
maybe it's a stupid question but i can't resolve this big problem!!
thanky you all
This content has not been rated yet. 
31 Reputation 3 Total posts
shawndg

shawndg

5/15/2012 8:18:54 PM
In design mode, this happens to me all the time..

I pretty much strickly work right from the HTML markup and code by hand.
I dont like WYUSIWUG editors.

However, once you run the site, it should still work with out to many issues..

I dont know if there any good way around the errors inside the visual layout..
You may be able to add the dll references, but I don't know.

When I test, I just run visual studio and preview with a browser but code everything via markup..
This content has not been rated yet. 
1871 Reputation 252 Total posts
khorvat

khorvat

5/15/2012 9:40:59 PM
Hi,

some modules do support design mode but some of them don't because of they are dependent upon ASP.NET personalization and some other settings that are basically saved in the database. Most of the VS releases didn't work properly in the design mode and our users had nothing but problems so our suggestion would be to use mark-up view for development and browser preview for testing as Shawndg mentioned. 

Let us know if you need more help on this.

Regards 
This content has not been rated yet. 
15993 Reputation 2214 Total posts
stefstef

stefstef

5/16/2012 6:02:19 PM
thank you all !! for the quickly response and the disponibility... i wanted to be sure that it don't was my fault...
i can work around...
thank you!
Shawndg great site btw!
This content has not been rated yet. 
31 Reputation 3 Total posts
khorvat

khorvat

5/20/2012 6:44:50 AM
I'm marking this topic as closed. Please open a new one if you have any other questions
This content has not been rated yet. 
15993 Reputation 2214 Total posts