MonoX support board

Start the conversation, ask questions and share tips and solutions with fellow developers.

Non-registered users can only browse through our support boards. Please register now if you want to post your questions. It takes a second and it is completely free. Alternatively, you can log in without registration using your credentials at major sites such as Google, Microsoft Live, OpenId, Facebook, LinkedIn or Yahoo.

Error when Upgrading to the latest MonoX Nightly version (Closed) (Mono Support )

Viewed 16606 time(s), 6 post(s) 11/20/2013 1:03:42 AMby bkkmono
bkkmono

bkkmono

11/20/2013 1:11:53 AM
Now, I use MonoX version v4.8.40.4594, DB v4.7.3842 for my site. I want to upgrade it to the current nightly version: 4.8.40.4839 (11/15/2013).

I have read this tutorial from the blog of monoX: http://www.mono-software.com/blog/post/Mono/86/Upgrading-to-new-MonoX-version/. I tried to do what it teaches me.

I deleted the bin folder of the existing installation and then I replaced the bin folder of the latest Nightly version. There was an error on my site. The following error message was displayed:
This event has been logged and will be addressed by the maintenance department. We appreciate your patience.
 
Could not load type 'System.Runtime.CompilerServices.ExtensionAttribute' from assembly 'mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089'.
at System.ModuleHandle.ResolveType(RuntimeModule module, Int32 typeToken, IntPtr* typeInstArgs, Int32 typeInstCount, IntPtr* methodInstArgs, Int32 methodInstCount, ObjectHandleOnStack type) at System.ModuleHandle.ResolveTypeHandleInternal(RuntimeModule module, Int32 typeToken, RuntimeTypeHandle[] typeInstantiationContext, RuntimeTypeHandle[] methodInstantiationContext) at System.ModuleHandle.ResolveTypeHandle(Int32 typeToken, RuntimeTypeHandle[] typeInstantiationContext, RuntimeTypeHandle[] methodInstantiationContext) at System.Reflection.RuntimeModule.ResolveType(Int32 metadataToken, Type[] genericTypeArguments, Type[] genericMethodArguments) at System.Reflection.CustomAttribute.FilterCustomAttributeRecord(CustomAttributeRecord caRecord, MetadataImport scope, Assembly& lastAptcaOkAssembly, RuntimeModule decoratedModule, MetadataToken decoratedToken, RuntimeType attributeFilterType, Boolean mustBeInheritable, Object[] attributes, IList derivedAttributes, RuntimeType& attributeType, IRuntimeMethodInfo& ctor, Boolean& ctorHasParameters, Boolean& isVarArg) at System.Reflection.CustomAttribute.GetCustomAttributes(RuntimeModule decoratedModule, Int32 decoratedMetadataToken, Int32 pcaCount, RuntimeType attributeFilterType, Boolean mustBeInheritable, IList derivedAttributes, Boolean isDecoratedTargetSecurityTransparent) at System.Reflection.CustomAttribute.GetCustomAttributes(RuntimeAssembly assembly, RuntimeType caType) at System.Web.UI.AssemblyCache.GetAjaxFrameworkAssemblyAttribute(Assembly assembly) at System.Web.UI.ScriptManager.get_DefaultAjaxFrameworkAssembly() at System.Web.UI.ScriptManager..ctor() at ASP.monox_masterpages_main_master.__BuildControlform1() at ASP.monox_masterpages_main_master.__BuildControlTree(monox_masterpages_main_master __ctrl) at System.Web.UI.MasterPage.CreateMaster(TemplateControl owner, HttpContext context, VirtualPath masterPageFile, IDictionary contentTemplateCollection) at System.Web.UI.MasterPage.get_Master() at System.Web.UI.MasterPage.ApplyMasterRecursive(MasterPage master, IList appliedMasterFilePaths) at System.Web.UI.MasterPage.ApplyMasterRecursive(MasterPage master, IList appliedMasterFilePaths) at System.Web.UI.MasterPage.ApplyMasterRecursive(MasterPage master, IList appliedMasterFilePaths) at System.Web.UI.Page.PerformPreInit() at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
What happened to my site?
 How to upgrade the existing version to the latest nightly version?
This content has not been rated yet. 
434 Reputation 51 Total posts
khorvat

khorvat

11/20/2013 8:20:51 AM
Hi,

this is MS .NET backward compatibility issue. Microsoft moved ExtensionAttribute to a different assembly and now some projects built on the machines that have .NET 4.5 installed break the .NET 4.0 assemblies (http://stackoverflow.com/a/13750130/467991). 

So right now you can install .NET 4.5 on the machine as one option, or I can try to send you MonoSoftware.Framework assemblies built on another machine just to try to avoid the issue you are having.

Let me know what option suites you better.

Regards
Rated 5.00, 1 vote(s). 
15993 Reputation 2214 Total posts
bkkmono

bkkmono

11/20/2013 8:45:05 AM
I should install .NET 4.5 on my machine and select using .NET 4.5 instead of .NET 4.0 from the application pool of my site on IIS7.
Should I do this?
This content has not been rated yet. 
434 Reputation 51 Total posts
khorvat

khorvat

11/20/2013 9:05:34 AM
You just need to install it, I think you don'r event have to choose the .NET 4.5 for your app pool. So just install it and get back to us.

Regards
This content has not been rated yet. 
15993 Reputation 2214 Total posts
bkkmono

bkkmono

11/20/2013 10:38:20 AM
.NET 4.5 installed, I am upgrading my site, the new version of MonoX is working with no problem.

Thanks for your suggestion.
Rated 5.00, 1 vote(s). 
434 Reputation 51 Total posts
khorvat

khorvat

11/20/2013 10:49:58 AM
Np, let us know if you need anything else.

Regards
This content has not been rated yet. 
15993 Reputation 2214 Total posts