MonoX support board

Start the conversation, ask questions and share tips and solutions with fellow developers.

Non-registered users can only browse through our support boards. Please register now if you want to post your questions. It takes a second and it is completely free. Alternatively, you can log in without registration using your credentials at major sites such as Google, Microsoft Live, OpenId, Facebook, LinkedIn or Yahoo.

How to disable options from search ?  (Mono Support )

Viewed 6428 time(s), 14 post(s) 1/11/2013 8:43:07 PMby super
super

super

1/15/2013 8:08:10 PM
Should I just remove this completely from web config ?

<add name="CalendarEventSearchProvider" type="MonoSoftware.MonoX.SearchEngine.Providers.CalendarEventSearchProvider, MonoX" BoldSearchPhrases="true" CalendarEventPreviewPagePath="/MonoX/Pages/SocialNetworking/EventCalendar.aspx" MaxNoOfResults="100" />
This content has not been rated yet. 
6018 Reputation 709 Total posts
super

super

1/15/2013 8:10:46 PM
Removing this line from webconfig did the trick - thanks
This content has not been rated yet. 
6018 Reputation 709 Total posts
khorvat

khorvat

1/17/2013 8:09:54 AM
Hi Super & Sam0864 

it's not good practice to remove search providers from the web.config because that doesn't solve you issue properly, this way you have removed the provider entirely from the app, while removing that provider from the code I have pointed will remove it from only that WebPart. The step you both were missing is resetting personalization for that Zone as WebPart properties are saved in the database so that's why you didn't see any changes every time you changed the WebPart settings in the mark-up. 

Regards
This content has not been rated yet. 
15993 Reputation 2214 Total posts
super

super

1/20/2013 9:21:48 PM
khorvat, I tried your way and even after resetting personalization in the administration for searchresult page doesn't do anything...

any advise ?
This content has not been rated yet. 
6018 Reputation 709 Total posts
1 2