MonoX support board

Start the conversation, ask questions and share tips and solutions with fellow developers.

Non-registered users can only browse through our support boards. Please register now if you want to post your questions. It takes a second and it is completely free. Alternatively, you can log in without registration using your credentials at major sites such as Google, Microsoft Live, OpenId, Facebook, LinkedIn or Yahoo.

Only admin can browse discussion board (Closed) (Mono Support )

Viewed 40340 time(s), 14 post(s) 8/18/2011 5:35:21 AMby VanDemon
VanDemon

VanDemon

8/19/2011 5:50:15 AM
hi... this has been resolved....


for some reason permissions were incorrect for the \Upload\user\ subfolders and that caused the issue.
This content has not been rated yet. 
141 Reputation 20 Total posts
VanDemon

VanDemon

8/18/2011 6:41:40 AM
I've created new users and also tried existing users but both get redirected to error page when trying to access the discussion board.

any ideas?
This content has not been rated yet. 
141 Reputation 20 Total posts
denis

denis

8/18/2011 6:54:11 AM
Hi,
Could you post the exact error message here?
This content has not been rated yet. 
7207 Reputation 956 Total posts
VanDemon

VanDemon

8/18/2011 7:06:17 AM
the error message is

"An error has occured in the application.
This event has been logged and will be addressed by the maintenance department. We appreciate your patience.

To continue working with the application please click here "
This content has not been rated yet. 
141 Reputation 20 Total posts
denis

denis

8/18/2011 7:19:00 AM
Please take a look in the /MonoX/ApplicationData/Logs folder, and locate the newest MonoX.log file, it should contain the detailed error message - please post it here.
This content has not been rated yet. 
7207 Reputation 956 Total posts
VanDemon

VanDemon

8/18/2011 7:21:34 AM
this is the latest log....

2011-08-16 13:40:41,469 [4] ERROR MonoX [BaseHttpApplication] - Application Error
System.Web.HttpException (0x80004005): File does not exist.
at System.Web.StaticFileHandler.GetFileInfo(String virtualPathWithPathInfo, String physicalPath, HttpResponse response)
at System.Web.StaticFileHandler.ProcessRequestInternal(HttpContext context, String overrideVirtualPath)
at System.Web.DefaultHttpHandler.BeginProcessRequest(HttpContext context, AsyncCallback callback, Object state)
at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)
2011-08-16 13:40:41,856 [7] ERROR MonoX [BaseHttpApplication] - Application Error
System.Web.HttpException (0x80004005): File does not exist.
at System.Web.StaticFileHandler.GetFileInfo(String virtualPathWithPathInfo, String physicalPath, HttpResponse response)
at System.Web.StaticFileHandler.ProcessRequestInternal(HttpContext context, String overrideVirtualPath)
at System.Web.DefaultHttpHandler.BeginProcessRequest(HttpContext context, AsyncCallback callback, Object state)
at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)
2011-08-16 13:42:21,245 [9] ERROR MonoX [BaseHttpApplication] - Application Error
System.Web.HttpException (0x80004005): File does not exist.
at System.Web.StaticFileHandler.GetFileInfo(String virtualPathWithPathInfo, String physicalPath, HttpResponse response)
at System.Web.StaticFileHandler.ProcessRequestInternal(HttpContext context, String overrideVirtualPath)
at System.Web.DefaultHttpHandler.BeginProcessRequest(HttpContext context, AsyncCallback callback, Object state)
at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)
This content has not been rated yet. 
141 Reputation 20 Total posts
denis

denis

8/18/2011 7:28:29 AM
I was suspecting that URL rewriting is not turned on in your IIS, but in that case no users would be able to access the forum (even admins). Can you access the blog (as it is also using the URL rewriting). Which version of IIS and Windows are you using?
This content has not been rated yet. 
7207 Reputation 956 Total posts
VanDemon

VanDemon

8/18/2011 7:31:00 AM
the blog cannot be accessed either.

it is a machine we built for testing on 2008 server r2 and latest iis 7.5
This content has not been rated yet. 
141 Reputation 20 Total posts
khorvat

khorvat

8/18/2011 7:40:38 AM
Hi,

  do you run .NET 3.5 or 4.0 and does your application pool runs under the Classic or Integrated mode ?

Regards 

This content has not been rated yet. 
15993 Reputation 2214 Total posts
VanDemon

VanDemon

8/18/2011 7:42:04 AM
hi...

it's integrated 4.0
This content has not been rated yet. 
141 Reputation 20 Total posts
khorvat

khorvat

8/18/2011 8:44:24 AM
At this point we are not sure what maybe causing this error so we need more information, can you provide us with the URL for which you get the error ?

Regards
This content has not been rated yet. 
15993 Reputation 2214 Total posts
1 2