MonoX support board

Start the conversation, ask questions and share tips and solutions with fellow developers.

Non-registered users can only browse through our support boards. Please register now if you want to post your questions. It takes a second and it is completely free. Alternatively, you can log in without registration using your credentials at major sites such as Google, Microsoft Live, OpenId, Facebook, LinkedIn or Yahoo.

Blog link is not working (Closed) (Mono Support )

Viewed 27170 time(s), 9 post(s) 10/18/2011 5:43:45 AMby ashutosh0901

Related topics

ashutosh0901

ashutosh0901

10/18/2011 5:43:46 AM
when i click on the blog it makes this url http://localhost/MonoX45Latest/blog/posts/MonoX/ but it doesnt work. it say "The page cannot be found"
This content has not been rated yet. 
353 Reputation 46 Total posts
khorvat

khorvat

10/18/2011 6:35:39 AM
Hi,

can you tell us your hosting environment specifications (Win version, IIS version, .Net version, Application pool mode etc.) ?

Regards
This content has not been rated yet. 
15993 Reputation 2214 Total posts
ashutosh0901

ashutosh0901

10/18/2011 6:42:39 AM
Operating System- Window XP
IIS Version V5.1
.Net Version VS 2010
Framework 4.0
Application Pool Default


Few Links are working like disscusion is working but blog, blog content and user profile these are few links which are not working
This content has not been rated yet. 
353 Reputation 46 Total posts
khorvat

khorvat

10/18/2011 6:56:18 AM
On the IIS 5.1 you need to add a wild-card to the mappings to get the URL rewriting to work properly. Please refer to MonoX manual Section "2.5.1.1 URL rewriting"

Let us know if you have managed to get URL rewriting to work properly.

Regards
This content has not been rated yet. 
15993 Reputation 2214 Total posts
ashutosh0901

ashutosh0901

10/18/2011 7:21:26 AM
Not able to find anything for IIS 5.1 its all about 6.0 and 7.0
This content has not been rated yet. 
353 Reputation 46 Total posts
khorvat

khorvat

10/18/2011 7:45:40 AM
You can use same settings as IIS 6 to configure IIS 5.1, map .* to aspnet_isapi.dll, like any other ASP.NET handler.

1. Open IIS Manager. Make sure it’s the OLD IIS manager that comes with XP. If you go to Help -> About Internet Information Services it should show version 5.1, not 6.0.
2. Right-click your virtual directory application and hit PropertiesIf it isn’t already, make sure the virtual directory is an Application
3. Click Configuration.Find out what the DLL path for .aspx is by selecting it from the list and click edit.
4. Add a new extension, putting the path from the .aspx extension in the Executable field.
5. In the extension field, put “.*” (without quotes). uncheck “Check that file exists.” click OK. 
6. Save your settings and it should work!

Regards
This content has not been rated yet. 
15993 Reputation 2214 Total posts
ashutosh0901

ashutosh0901

10/18/2011 9:09:59 AM
Extension is not editable .......what should i do?
This content has not been rated yet. 
353 Reputation 46 Total posts
ashutosh0901

ashutosh0901

10/18/2011 9:25:18 AM
Thank you that solved my problem ...
This content has not been rated yet. 
353 Reputation 46 Total posts
khorvat

khorvat

10/18/2011 10:29:21 AM
Great let us know if you need anything else.

Regards
This content has not been rated yet. 
15993 Reputation 2214 Total posts