MonoX support board

Start the conversation, ask questions and share tips and solutions with fellow developers.

Non-registered users can only browse through our support boards. Please register now if you want to post your questions. It takes a second and it is completely free. Alternatively, you can log in without registration using your credentials at major sites such as Google, Microsoft Live, OpenId, Facebook, LinkedIn or Yahoo.

Integrating BlogEngine.Net (Closed) (Mono Support )

Viewed 34241 time(s), 7 post(s) 9/23/2008 4:44:02 PMby denis
denis

denis

6/2/2011 9:52:03 AM
BlogEngine.Net is another world-class third-party software that can be fully integrated with MonoX. Please use the attached web.config file and modify the LocalSqlServer connection string to match your local settings.

Note: this configuration file is to be used with the version 1.4.5 of BlogEngine.Net.
This content has not been rated yet. 
7207 Reputation 956 Total posts
dckidd

dckidd

11/27/2008 4:19:13 PM
The forum integration went well. This one does not however. I get an error when trying to bring up BlogEngine URL:

Could not load file or assembly 'System.Web.Extensions.Design, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.
This content has not been rated yet. 
0 Reputation 1 Total posts
denis

denis

11/30/2008 2:49:56 PM
This obiously means that you don't have ASP.NET 2.0 AJAX Extensions 1.0 installed on your machine. This assembly is used by the parent application (MonoX), and all settings from the parent MonoX web.config are propagated to the Blog web.config, however the correct DLL cannot be found in the BlogEngine bin folder. You may fix this issue by using any of the following:

1. install ASP.NET 2.0 AJAX Extensions 1.0
2. copy the System.Web.Extensions.dll and System.Web.Extensions.Design.dll from the MonoX /bin folder to the BlogEngine /bin folder
3. add the following tags in the section of the BlogEngine Web.config



Regards,

Denis
This content has not been rated yet. 
7207 Reputation 956 Total posts
super

super

7/17/2012 4:28:48 PM
hello dennis,

This solution is good when MonoX is the parent and BlogEngine is in a folder ? Or BlogEngine is parent and monox is in a folder ?
This content has not been rated yet. 
6018 Reputation 709 Total posts
super

super

7/17/2012 4:39:32 PM
I just followed your webconfig and trying with new BlogEngine 2.5 with current monoX version.

I have placed MonoX in a sub folder named as "/MonoX"

My main project is BlogEngine, did everything based on your webconfig (above), getting error messages:

12 'MonoSoftware' is not declared. It may be inaccessible due to its protection level
13 'MonoSoftware' is not declared. It may be inaccessible due to its protection level

(Pointing to: /MonoX/App_Templates/Default/BlogTemplates/BlogList.ascx)

FYI: I have disabled the webconfig inside monoX like this "web.config.exclude" because I am using main project as BlogEngine, so I have added monoX stuff in blog engine webconfig (based on your provided webconfig above)

Please help.
This content has not been rated yet. 
6018 Reputation 709 Total posts
super

super

7/17/2012 4:54:56 PM
Also, when I try to view /MonoX/Default.aspx in the browser, still I see blogengine solution ? why ?

Still I am getting the above 2 error messages.
This content has not been rated yet. 
6018 Reputation 709 Total posts
khorvat

khorvat

7/23/2012 9:05:20 AM
As you have moved your discussion to another topic I'm closing this one.

Regards
This content has not been rated yet. 
15993 Reputation 2214 Total posts