MonoX support board

Start the conversation, ask questions and share tips and solutions with fellow developers.

Non-registered users can only browse through our support boards. Please register now if you want to post your questions. It takes a second and it is completely free. Alternatively, you can log in without registration using your credentials at major sites such as Google, Microsoft Live, OpenId, Facebook, LinkedIn or Yahoo.

Hello, i tried finally install Mono on separate hosting, and it doesn't proceed.  (Mono Support )

Viewed 124441 time(s), 46 post(s) 1/19/2012 10:11:02 PMby in4man
in4man

in4man

2/2/2012 12:43:48 AM
I want, maybe to contact my hosting provider. Th4t i Use. If no will try find other. Thanks. I want non-commercial project, so I don't want to pay for hosting.
This content has not been rated yet. 
282 Reputation 46 Total posts
in4man

in4man

2/4/2012 6:09:51 PM
Hi, its again me. I tried use another MS SQL hosting, but still Finish button don't work properly.
If i somehow understand the error, you provided, that it seems you use SOME Library that has version another from Hosting One... So, maybe you will try use other assembly, or you can tell me what to change And I will changed the corresponding library. (I ensured that MS SQL hosting works, cause I put IP address in MonoX installer, and it showed me databases.)

Please assist ME! I will look for your reply.
This content has not been rated yet. 
282 Reputation 46 Total posts
khorvat

khorvat

2/5/2012 12:14:31 AM
Hi,

the error that I have provided you with isn't related to MonoX we get that error when we try to execute the create script from the hosting provider SQL Web UI. We will try to review the script and check if it contains the SQL 2008 version specific statements and get back to you.

In the meanwhile can you provide us with the error you get this time ? In most cases when "finish" button "doesn't work" web.config file doesn't have write permissions and you are redirected back to the install wizard. 

Regards 
This content has not been rated yet. 
15993 Reputation 2214 Total posts
in4man

in4man

2/5/2012 8:06:44 AM
hi, it's no specific error, only not working button (no action or event fired VISUALLY). I think so, too, that it something with web.config. But not imaging what exactly. Could you tell me what files are being writen when finish presses — so that I can tell to hosting what conrete file are not have permissions. Maybe we can solve this issue by granting permissions.

P.S. i have one idea, so i will try it now (to pass Identity impersonate=true with correct username and password).
This content has not been rated yet. 
282 Reputation 46 Total posts
in4man

in4man

2/5/2012 8:16:24 AM
no, with identity impersonate true = is not solving finish button (by the way, advanced settings button in last screen IS NOT WORKING Too...) Maybe it's not right with viewstate... like in previous buttons?
This content has not been rated yet. 
282 Reputation 46 Total posts
khorvat

khorvat

2/5/2012 9:48:13 AM
Hi,

the only thing that I noticed is that for some reason MonoX installed on your hosting provider performs callbacks every 1-5secs and I seems to me that this happens because of some collision introduced by the injected content from your hosting provider.

Can you please provide us with the access to new hosting provider account so we can take a look at that installation.

Regards
This content has not been rated yet. 
15993 Reputation 2214 Total posts
in4man

in4man

2/5/2012 9:52:16 AM
Yeas, I can tell you new account information for ASP.NET hosting, but I registered it and it still has "Account confirmation pending..." status. So when It will be pended (confirmed) I send you details. But if you thought I got the same error on new hosting, it's not true, because I registered ONLY MS SQL database hosting (free as is) Without asp.net...

P.S. wait some time till my account on my new hosting will be approved.
This content has not been rated yet. 
282 Reputation 46 Total posts
in4man

in4man

2/6/2012 1:07:36 AM
Hi! I am with good news. I configured mono ON my pc, and uploaded it to hosting, to ms sql hosting and all works.
(for so i don't reached to check aLL... but VOI LA. named-is.somee.com here you can see. But uploading files not working. I tried images, and so I wrote Identity impersonate="true" my user name password, dont works. I got error dmz/host/named_is.somee.com/Upload not granted permisions for upload (write). What it can be? ) Thanks. In advance. (For still you can login for my hosting and see whatever you want.)
This content has not been rated yet. 
282 Reputation 46 Total posts
in4man

in4man

2/6/2012 1:14:01 AM
and second bug, when I try use second language (Russian). I found that top menu DISSAPEARS. I translated Resource via project Localization and compile in visual studio. And top menu in English is present, but dissapears in Russian. What's is it?
This content has not been rated yet. 
282 Reputation 46 Total posts
denis

denis

2/6/2012 12:27:34 PM
Upload problems can be solved by setting correct security permissions on the folders that you plan to use for uploading files. The Windows account under which your application pool runs (NETWORK SERVICE or something like that, depending on your installation and IIS version) must have write privileges.

As for the "dissapearing menu" issue, this behavior is by design. Links displayed in the menu are actually not held in localization resources, you can pleace whatever you want in there via Page administration panel in the backend admin. Different languages do not have to follow the navigation structure of the original language, and MonoX allows total freedom in creating independent navigation hierarchy for each language.
This content has not been rated yet. 
7207 Reputation 956 Total posts
1 2 3 4 5