MonoX support board

Start the conversation, ask questions and share tips and solutions with fellow developers.

Non-registered users can only browse through our support boards. Please register now if you want to post your questions. It takes a second and it is completely free. Alternatively, you can log in without registration using your credentials at major sites such as Google, Microsoft Live, OpenId, Facebook, LinkedIn or Yahoo.

How to change the blog comment settings so no comment approval required ?  (Mono Support )

Viewed 14370 time(s), 6 post(s) 12/10/2012 9:47:13 PMby super
super

super

12/10/2012 9:48:38 PM
How to change the blog comment settings so no comment approval required ?

Right now it is not user-friendly for any member to get each comment approved by admin. In those cases when multiple users are posting a lot of comments and discussions are going on, it can be annoying for any user to post comment and wait for admin's approval.

How to DISABLE this approval thing for blog comments ?

I think approval is required for a user first time only in monox, right ?

Still how to remove this approval thing ?
This content has not been rated yet. 
6018 Reputation 709 Total posts
mzilic

mzilic

12/10/2012 10:14:12 PM
Hello,

Please see the following topic for all available options and a solution.

Regards,
Mario
This content has not been rated yet. 
2218 Reputation 300 Total posts
super

super

2/19/2014 3:40:48 PM
How to achieve this in 4.9 version ? as I do not see any <MonoX:BlogComments> in 4.9 version
This content has not been rated yet. 
6018 Reputation 709 Total posts
mzilic

mzilic

2/20/2014 2:05:57 PM
Hello,

The ApprovalMode is still available in the BlogComments control.

Regards
This content has not been rated yet. 
2218 Reputation 300 Total posts
super

super

3/13/2014 3:25:23 PM
Ok..so in  the location: /MonoX/ModuleGallery/Blog/BlogContainer file

I have this:

<MonoX:BlogComments ID="blogComments" runat="server" ApprovalMode="None"/>

Still the comments needs my approval, why ?

This content has not been rated yet. 
6018 Reputation 709 Total posts
khorvat

khorvat

3/13/2014 4:01:59 PM
You have to set the ApprovalMode on the BlogContainer control and not the MonoX:BlogComments in order to apply the setting.
This content has not been rated yet. 
15993 Reputation 2214 Total posts