MonoX support board

Start the conversation, ask questions and share tips and solutions with fellow developers.

Non-registered users can only browse through our support boards. Please register now if you want to post your questions. It takes a second and it is completely free. Alternatively, you can log in without registration using your credentials at major sites such as Google, Microsoft Live, OpenId, Facebook, LinkedIn or Yahoo.

Event Calendar - Advanced - bug with navigation and display update  (Mono Support )

Viewed 50637 time(s), 29 post(s) 4/9/2012 8:48:54 AMby Jeremy
khorvat

khorvat

4/14/2012 9:50:15 AM
Hi,

you need to go to Portal Administration, Page Management, find the Default.aspx, Right Click and select Manage Web Parts. In the opened pop-up click on the "Click here if you want to reset the personalization for the selected page. NOTE: this will remove all dynamically added Web parts and their settings."

Let me know the results.

Regards
This content has not been rated yet. 
15993 Reputation 2214 Total posts
Jeremy

Jeremy

4/14/2012 10:00:23 AM
I reset the web parts on default.aspx, which removed my event calendar. I then tried to re-add it but I am getting the same error message. There was an error in the callback.
This content has not been rated yet. 
322 Reputation 36 Total posts
khorvat

khorvat

4/14/2012 10:35:13 AM
Hi,

can you please try to add (reference) manually WebPart to Default.aspx and place it outside of the WebPartZone, we need to see if this is related to WebPart properties being set to the WebPart or something else.

Also did you perform any changes in the mark-up on the Event WebParts ?

Regards
This content has not been rated yet. 
15993 Reputation 2214 Total posts
Jeremy

Jeremy

4/14/2012 11:01:47 AM
I have added the event calendar manually to default.aspx outside of the web part zone. It displays properly.
<%@ Register TagPrefix="MonoX" TagName="Event"
Src="/MonoX/ModuleGallery/EventModule/EventModule.ascx"
%>
<monox:Event ID="CabinBookingsCalendar" runat="server"
CalendarName="CabinBookings" Mode="Advanced" AdvancedModeDefaultView="MonthView"
></monox:Event>

I have not made any changes to the mark-up on the event web parts.
This content has not been rated yet. 
322 Reputation 36 Total posts
Jeremy

Jeremy

4/14/2012 12:50:54 PM
To troubleshoot further, I tried doing a fresh "out of the box" installation, including an empty database. It fails with the following message:

2012-04-14 22:50:55Z: Cannot insert the value NULL into column 'CalendarId', table 'monoxbeta.dbo.CalendarEvent'; column does not allow nulls. INSERT fails. Inserting values into [dbo].[CalendarEvent] The statement has been terminated.
This content has not been rated yet. 
322 Reputation 36 Total posts
Jeremy

Jeremy

4/14/2012 1:10:00 PM
The errors I am getting can be reproduced by doing a clean installation using the unofficial version (MonoX v4.7.40.3474 [4/13/2012]).

Even though the install fails, you can re-run the installation using the same database that was partially created. Open the homepage and drag in an Event Module to a web part zone. Try to set a calendar and you will get the same error messages that I have been reporting.

Could you let me know if you are able to reproduce these errors with the Event Module web part?
This content has not been rated yet. 
322 Reputation 36 Total posts
khorvat

khorvat

4/14/2012 1:39:29 PM
Hi,

we aren't able to reproduce it, Event module is working fine on few of existing 4.7.40.34xx installations, we need to setup clean environment so we can test it. We will let you know the test results soon.

Note: As this is unofficial version, installation is not up to date, we have provided you with this version mainly for upgrade purposes. If you need a clean install we can try to upgrade MonoX installation wizard during the next week, so let me know.

Regards
This content has not been rated yet. 
15993 Reputation 2214 Total posts
Jeremy

Jeremy

4/14/2012 10:13:18 PM
I do not need a working clean install. I was just trying to narrow down the problem to make it easier to reproduce.
This content has not been rated yet. 
322 Reputation 36 Total posts
khorvat

khorvat

4/17/2012 11:09:26 AM
Hi,

we have reproduced the issue on our end, we will provide you with solution soon, stay tuned.

Regards
This content has not been rated yet. 
15993 Reputation 2214 Total posts
khorvat

khorvat

4/18/2012 10:27:50 AM
We have fixed the issue and we will try to provide you with the download URL today.

Regards
This content has not been rated yet. 
15993 Reputation 2214 Total posts
1 2 3