MonoX support board

Start the conversation, ask questions and share tips and solutions with fellow developers.

Non-registered users can only browse through our support boards. Please register now if you want to post your questions. It takes a second and it is completely free. Alternatively, you can log in without registration using your credentials at major sites such as Google, Microsoft Live, OpenId, Facebook, LinkedIn or Yahoo.

The parameter 'username' must not contain commas. Parameter name: username  (Mono Support )

Viewed 19553 time(s), 10 post(s) 5/23/2013 5:14:36 PMby mev9669
mev9669

mev9669

5/23/2013 5:14:36 PM
Has someone encountered this error before? i get it when I click on edit profile on the user profile page. i get the same error when i click on the page tasks actions menu that is browse mode, design mode etc.
This content has not been rated yet. 
515 Reputation 67 Total posts
idrazic

idrazic

5/24/2013 11:33:02 AM
Hi,

Yes, it looks like "User Manager" allows any character to be entered for "User Name" but it shouldn't as SqlMembershipProvider doesn't allow commas (that seems to be the only problematic character). 

As a workaround you can try to edit the field manually and remove the comma.

I've filed a bug report about this and we will fix it as soon as possible.

Thanks!


This content has not been rated yet. 
1384 Reputation 152 Total posts
mev9669

mev9669

5/24/2013 11:45:57 AM
but the username I use is admin. And there is no comma in it.
This content has not been rated yet. 
515 Reputation 67 Total posts
idrazic

idrazic

5/24/2013 12:33:41 PM
Can you please check the actual data in the database?
Does this happen with default installation, if not can you provide a sample that triggers the error?  

Regards,
Igor
This content has not been rated yet. 
1384 Reputation 152 Total posts
mev9669

mev9669

5/24/2013 1:10:27 PM
This happens with the default installation of MonoX. I have not done anything with the users. i have just setup a few custom pages. 
This content has not been rated yet. 
515 Reputation 67 Total posts
mev9669

mev9669

5/24/2013 1:12:06 PM
Well, this happens when I click on edit button on the profile edit page with the default installation. 
This content has not been rated yet. 
515 Reputation 67 Total posts
mev9669

mev9669

5/24/2013 1:47:32 PM
The page url is domainname.com/profile-about/admin/


This content has not been rated yet. 
515 Reputation 67 Total posts
idrazic

idrazic

5/27/2013 7:56:01 AM
We had is issue before, source of the problem and possible solutions are offered here:
http://www.mono-software.com/Mono/Pages/Discussion/dtopic/x1XtGX4IcE-9R56KATl6gQ/I-have-latest-monox-up-and-running-Error-when-trying-to-design-or-edit-profile-pages/?dbmpageno=0 
This content has not been rated yet. 
1384 Reputation 152 Total posts
mev9669

mev9669

5/27/2013 9:21:14 AM
Hi Idrazic,

I have placed the  Form.broser in the App_Browsers folder and it works fine on the web server but does not work on my local development machine. Also it will be great if you can add some URL rewrite rules that you have used and explain them in the documentation.
Thanks very much for your help. 

is there a reason why the form.browser file wont display the login page which is placed in the root directory?
This content has not been rated yet. 
515 Reputation 67 Total posts
khorvat

khorvat

5/28/2013 11:09:39 AM
Let me try to fill in a few blanks here ...

This will work only in the scenario where you have a Form.browser in the App_Browsers folder and you have removed the App_Browsers.dll from your bin folder.
I have placed the  Form.broser in the App_Browsers folder and it works fine on the web server but does not work on my local development machine.
URL Rewriter used by MonoX can be found here. As MonoX doesn't implement any custom rules or anything you can find all the documentation you need on that link. Let us know if you need any more information regarding the rewriting ?
Also it will be great if you can add some URL rewrite rules that you have used and explain them in the documentation.

Form Adapter (Form.browser) is used to rewrite the HTML Form action attribute on all forms in MonoX to get URL rewriting ability and to fix the postback issues when you use rewriting etc. Login page is not rewritten so there should be any link between those two.
is there a reason why the form.browser file wont display the login page which is placed in the root directory?
Regards
This content has not been rated yet. 
15993 Reputation 2214 Total posts