MonoX support board

Start the conversation, ask questions and share tips and solutions with fellow developers.

Non-registered users can only browse through our support boards. Please register now if you want to post your questions. It takes a second and it is completely free. Alternatively, you can log in without registration using your credentials at major sites such as Google, Microsoft Live, OpenId, Facebook, LinkedIn or Yahoo.

Error log files empty.  (Mono Support )

Viewed 6175 time(s), 8 post(s) 7/29/2013 2:44:56 PMby mev9669
mev9669

mev9669

7/29/2013 2:44:56 PM
Regarding my earlier post http://www.mono-software.com/Mono/Pages/Discussion/dtopic/eVxOVGw2iEaR6KIKAOZk1w/Error-Logs/ , I manages to get the log files created in the folder. but the files are currently empty. I also tried downloading the files using filezilla client and i get an error 550 The process cannot access the file because it is being used by another process. 

This content has not been rated yet. 
515 Reputation 67 Total posts
mzilic

mzilic

7/29/2013 2:52:54 PM
Hello,

This is probably because the Application Pool most likely locked the files. Can you try connecting using Remote Desktop and downloading the logs or stopping the site temporarily in order to try and download the logs.

Regards,
Mario
This content has not been rated yet. 
2218 Reputation 300 Total posts
mev9669

mev9669

7/29/2013 3:07:29 PM
I have downloaded the file and found the following error.

2013-07-29 15:51:06,389 [12] ERROR MonoX [5.2.96.91] - An error has occured while sending you an e-mail. Please try again, if the problem persists, please contact us.at MonoSoftware.MonoX.Mail.MonoXMailSender.SendMail(MailMessage mailMsg)at MonoSoftware.Core.Mail.MailSender.SendMail(MailAddress fromAddress, String toAddress, String title, String htmlContent, String plainContent)at MonoSoftware.Core.Mail.MailSender.SendMail(String toAddress, String title, String htmlContent, String plainContent)at MonoSoftware.MonoX.ModuleGallery.ActivationEmailRecovery.btnSend_Click(Object sender, EventArgs e)Server does not support secure connections.at System.Net.Mail.SmtpConnection.GetConnection(ServicePoint servicePoint)at System.Net.Mail.SmtpTransport.GetConnection(ServicePoint servicePoint)at System.Net.Mail.SmtpClient.GetConnection()at System.Net.Mail.SmtpClient.Send(MailMessage message)at MonoSoftware.Core.Mail.MailSender.SendMail(MailMessage mailMsg)
This content has not been rated yet. 
515 Reputation 67 Total posts
vzakanj

vzakanj

7/29/2013 3:12:00 PM
Hi MEV9669, could you please check your SMTP settings and possibly post them here?
This content has not been rated yet. 
345 Reputation 61 Total posts
mev9669

mev9669

7/29/2013 3:22:48 PM
<mailSettings>
      <smtp deliveryMethod="Network">
        <network host="mail......com" userName="admin@....com" password="...."  enableSsl="false" />
      </smtp>
    </mailSettings>
This content has not been rated yet. 
515 Reputation 67 Total posts
mzilic

mzilic

7/29/2013 3:29:26 PM
Hello,

Is the mailserver on the same machine as your website? Have you configured SMTP?

Regards,
Mario
This content has not been rated yet. 
2218 Reputation 300 Total posts
mev9669

mev9669

7/29/2013 3:32:14 PM
Yes. The mail server is the same server. the SMTP is configured by the IT company.
This content has not been rated yet. 
515 Reputation 67 Total posts
mzilic

mzilic

7/29/2013 3:38:55 PM
Hello,

Are you using IIS SMTP? If you are using IIS SMTP please check with the IT company if the localhost can access the SMTP. Also depending on the configuration you might need to adjust the host value in the configuration.

Regards,
Mario
This content has not been rated yet. 
2218 Reputation 300 Total posts