MonoX support board

Start the conversation, ask questions and share tips and solutions with fellow developers.

Non-registered users can only browse through our support boards. Please register now if you want to post your questions. It takes a second and it is completely free. Alternatively, you can log in without registration using your credentials at major sites such as Google, Microsoft Live, OpenId, Facebook, LinkedIn or Yahoo.

How do you create a poll or instantiate any of the included modules?  (Mono Support )

Viewed 22317 time(s), 5 post(s) 11/8/2010 6:05:50 PMby yousaid
yousaid

yousaid

11/8/2010 6:05:50 PM
Greetings,
This is probably something very simple, but I guess I am doing something wrong here. I am simply using the Demo project and attempting to customize it.
So I want to add a poll on the right side of the home page. here is what I have done:
Step 1.
I login as admin, then I click on "Change the look and funtionality of this page"
Step 2
I go to Portal administration and create a poll.
Step 3
I go to Page teasks and switch to Design view.
Step 4:
I select Part Catalog and from Main Web Module catalog, I then select Polls.
I click on Save and Close. Nothing happens.
Note:
The documentation says you should be able to drag and drop a web part from here, but that does not seem to be happening. Pretty sure I have followed the instructios on the Documentation, but seems like I am missing something.
[b]Can you please give me a step by step guide on how to display the poll I already have on the home page.[/b]
I have tried registering the Poll widget on the default page by dragging the user control to the Default.aspx.
cheers,
yousaid
This content has not been rated yet. 
206 Reputation 36 Total posts
denis

denis

11/8/2010 8:26:12 PM
Hi,
You were very close. In fact, only the third step is not neccessary since the portal is switched to the "catalog" mode when you select the part catalog and parts can be instantiated directly from it without switching to the design mode. You should already see the poll part, but without any data displayed in it. Is this correct?

If you already entered some data for your poll in the Poll management admin section (select it from the main admin screen, the direct URL is /MonoX/Admin/PollManager.aspx), all that remains to be done is to select the poll you want. Click on the "Properties" in the Web part menu and select your poll name in the Property editor that will be displayed in the admin toolbar. After you click "Ok" and the page is refreshed, you should be able to use your poll.
This content has not been rated yet. 
7207 Reputation 956 Total posts
yousaid

yousaid

11/11/2010 5:08:35 PM
Step 1.
I logged in as admin, then clicked on "go to portal administration...", click on Polls which brought me to
http://localhost/Mono40/MonoX/Admin/PollManager.aspx.
Step 2
Click on Add, Enter Poll Title, then Poll Question. Right below, I enter Poll Answers. I created a total of 3 different polls with 3 different answers.
Step 3
On the far right of the screen, I see a minimized webpart menu, below is the version number [b]v3.2.1789.35[10/1/2010]. [/b]I click on the minimized Icon to open it and Page tasks is opened.
Step 4:
I click on Part catalog, Module catalog Tab pops up. I click Module catalog Tab. Main Web part catalog (67) is listed among others. I select Main Web part catalog(67) to open it
Step 5:
From the list of listed webparts, I put a check mark next to Polls, and on the lower end of the page, I click on Add, then click on close.
comment: This is where I expect to see the properties you described or where to configure the webpart, but I don't see it.

So what am I missing?

fyi: I have even rinstalled twice, tried on IE 8, Firefox, Windows 7, WinXp but same results. As a last measure, I even deleted the logs and cache, but that did not help.
This content has not been rated yet. 
206 Reputation 36 Total posts
denis

denis

11/11/2010 8:25:33 PM
Hi,
In the step 5, depending on the page you are on, there will be a dropdown with the names of Web part zones next to the Add button (the caption says "Add to:"). For example, MonoX default home page contains three Web part zones (left, right, and featured projects zone). Here you can select which zone will host your newly added Poll part, and as soon as you click on the "Add" button it will be displayed in the selected zone.

Poll Web part is maybe a bit difficult to spot initially as it doesn't hold any content by default - its exact look depends on the chrome of the zone that hosts it (all of these concepts, parts, zones, chromes, etc. are explained in the manual). In any case, there will be a Web part menu - usually right below the selected part. This is where you should select "Properties" and set the poll you want to display.

If you still have problems with this, please contact us directly and we will guide you through the process.
This content has not been rated yet. 
7207 Reputation 956 Total posts
yousaid

yousaid

11/12/2010 9:17:05 PM
Greetings,
I got it working by downloading and reinstalling, and following same steps I have followed previously.
Thanks for your help.
yousaid
This content has not been rated yet. 
206 Reputation 36 Total posts