MonoX support board

Start the conversation, ask questions and share tips and solutions with fellow developers.

Non-registered users can only browse through our support boards. Please register now if you want to post your questions. It takes a second and it is completely free. Alternatively, you can log in without registration using your credentials at major sites such as Google, Microsoft Live, OpenId, Facebook, LinkedIn or Yahoo.

EnableSmtpSSL ignored by contact form  (Mono Support )

Viewed 9710 time(s), 4 post(s) 6/7/2016 5:33:53 PMby Zoomicon
Zoomicon

Zoomicon

6/7/2016 5:41:59 PM
  regarding this web.config setting:

    <!-- flag if SSL is enabled while sending an e-mail portal wide -->
      <add key="EnableSmtpSSL" value="false" />

seems that if one sets EnableSmtpSSL to true and then set their SMTP settings to connect to a local SMTP relay (say using the instructions at http://www.vsysad.com/2014/01/configure-iis-smtp-server-to-use-gmail-to-forward-messages/)

      <mailSettings>
        <smtp deliveryMethod="Network" from="xx@gmail.com">
          <network
            defaultCredentials="false"
            host="xxxxx.com"
            port="25"
            />
        </smtp>
      </mailSettings>

then the contact form WORKS, but the activation e-mail (and other email notifications) FAIL (when the local relay has been set to accept connections via Anonymous Authentication) with "System.Net.Mail.SmtpException: Server does not support secure connections."

turning that EnableSmtpSSL to false makes ALL work (both contact form and other e-mail actions)

so it seems the contact form IGNORES EnableSmtpSSL setting and uses false? Then obviously if the SMTP server requires SSL the contact form will fail?

for example I was trying to send to smtp.gmail.com using 587 port and having set that google acount (at account settings, not at gmail settings) to "allow less secure apps to connect"), but still the contact form was failing, whereas via the relay it works fine and sends to gmail (the relay takes care of it of course)




This content has not been rated yet. 
2793 Reputation 345 Total posts
slaven

slaven

6/8/2016 9:42:30 PM
Hi Zoomicon,

We will investigate this issue.
Which version of MonoX are you using ?

Best regards,
slaven
This content has not been rated yet. 
144 Reputation 22 Total posts
Zoomicon

Zoomicon

6/8/2016 9:52:43 PM
it's version
MonoX v4.9.40.4845 [12/25/2013], DB v4.7.3842
This content has not been rated yet. 
2793 Reputation 345 Total posts
Zoomicon

Zoomicon

6/10/2016 1:44:10 PM
btw, if others see this post and set up local SMTP mail relay (to send to Gmail or elsewhere), make sure you set SMTP service to Startup type Automatic, else at reboot the relays will stop
This content has not been rated yet. 
2793 Reputation 345 Total posts