MonoX support board

Start the conversation, ask questions and share tips and solutions with fellow developers.

Non-registered users can only browse through our support boards. Please register now if you want to post your questions. It takes a second and it is completely free. Alternatively, you can log in without registration using your credentials at major sites such as Google, Microsoft Live, OpenId, Facebook, LinkedIn or Yahoo.

Getting error while Logging into MonoX using Facebook Account  (Mono Support )

Viewed 16488 time(s), 11 post(s) 3/7/2013 7:01:34 AMby Deepti
Deepti

Deepti

3/7/2013 7:05:18 AM
Hi,

I am getting the below error when I try to log in Monox using my Facebook credentials:


This webpage has a redirect loopThe webpage at http://localhost/MonoXSetup/default.aspx#_=_ has resulted in too many redirects.
Clearing your cookies for this site or allowing third-party cookies may fix the problem. If not, it is possibly a server configuration issue and not a problem with your computer.

Here are some suggestions:
Reload this webpage later.
Learn more about this problem.

Error 310 (net::ERR_TOO_MANY_REDIRECTS): There were too many redirects.

I have created an app MonoXSetup using facebook developer and giving me error after I provide my Facebook credentials and it redirects to default.aspx.
I have made the required change in the value of ConsumerKey and ConsumerSecret in FacebookWrapper in web.config

Please help !!!

Thanks,
Deepti
This content has not been rated yet. 
65 Reputation 8 Total posts
khorvat

khorvat

3/7/2013 8:06:01 AM
Hi,

can you let us know what version of MonoX are you using ?

Thanks
This content has not been rated yet. 
15993 Reputation 2214 Total posts
Deepti

Deepti

3/7/2013 8:37:37 AM
Sure, I am using MonoX_4_7_40_4136

Thanks,
This content has not been rated yet. 
65 Reputation 8 Total posts
imarusic

imarusic

3/7/2013 9:25:23 AM
Hi Deepti,

can you please provide us with steps on how to reproduce it?

Regads.
This content has not been rated yet. 
3016 Reputation 428 Total posts
Deepti

Deepti

3/7/2013 9:34:47 AM
1) Create a dev app in facebook
2) Open MonoX website
3) Clicked on login button
4) On login page, click on facebook login
5) Enter facebook credentials
6) Popup of the Dev App appears
7) Skipped
8) Redirects to default.aspx
9) Got the above error...
This content has not been rated yet. 
65 Reputation 8 Total posts
imarusic

imarusic

3/7/2013 9:40:37 AM
Ok, we will test it and get back to you.

Regards.
This content has not been rated yet. 
3016 Reputation 428 Total posts
Deepti

Deepti

3/7/2013 9:44:34 AM
Ok Thanks !!!
This content has not been rated yet. 
65 Reputation 8 Total posts
tihomir-kit

tihomir.kit

3/8/2013 12:43:31 PM
Hi, we tested this on MonoX_4_7_40_4136 and were able to log in normally following the steps you provided. Have you been able to resolve this issue in the mean time?
This content has not been rated yet. 
526 Reputation 43 Total posts
Deepti

Deepti

3/12/2013 5:51:37 AM
No, I am still getting the same error..
Can you please tell me the required settings and the steps to follow from the start, so that I can integrate the functionality with my project.
It's critical, please reply soon....

Thanks,
Deepti
This content has not been rated yet. 
65 Reputation 8 Total posts
Deepti

Deepti

3/12/2013 8:26:56 AM
While creating dev app in facebook, I have given App Domain : localhost and Site URL: http://localhost/MonoXsetup 
Is this could be a reason of this error?

Thanks,
Deepti
This content has not been rated yet. 
65 Reputation 8 Total posts
1 2