MonoX support board

Start the conversation, ask questions and share tips and solutions with fellow developers.

Non-registered users can only browse through our support boards. Please register now if you want to post your questions. It takes a second and it is completely free. Alternatively, you can log in without registration using your credentials at major sites such as Google, Microsoft Live, OpenId, Facebook, LinkedIn or Yahoo.

Installation taking lot of time? (Closed) (Mono Support )

Viewed 7688 time(s), 4 post(s) 2/13/2012 3:52:01 PMby qurban

Related topics

qurban

qurban

2/14/2012 8:51:44 AM
Hi,
What i am trying to do?

Actually i am trying to create a custom project/application where i could use MonoX download and also should be enable to create new web parts.

1- I am bit confused about the installation..
Following steps i carried out and the installation is stuck... Any one if could help weather i should wait or did i do something wrong?

1- Created Webapplication and added both portal and projectname.sln files into it.
2- Copied all the files from unzipped MonoX 4
3- Click web application and clicked view in browser.
4- It asked me for database credential and i selected empty database option...

Any help?

2- If it installed and i want to create any web part let say Hello World. Will it require to compile to show in the part catalog?

thanks

Qurban


This content has not been rated yet. 
203 Reputation 15 Total posts
denis

denis

2/13/2012 7:07:31 PM
As for your installation problem, you should just unzip the files from the installation ZIP package, create a Web site that points to the folder where you extracted the files (the application pool bound to that site should run on the .NET version of your choice), create at least one address binding you will use to access the site, and than enter that address in the browser. SLN files are not needed at this point.

Now, looking at your screenshot it appears that you have a problem that appears when the application is installed on an overloaded SQL server in the shared hosting environment. Look here for more details: http://www.mono-software.com/Mono/Pages/Discussion/dtopic/CKc7xTS6P0S_Yp8RASn0mA/NA/?dmsgId=0EfkXhssSEuaPp8SAJftlg#Post0EfkXhssSEuaPp8SAJftlg

As for the Web part creation, the answer is yes, you will need to compile your own solution (you don't have to have the source code of MonoX for that). More details: http://www.mono-software.com/blog/post/Mono/95/Building-a-custom-ASP-NET-project-based-on-MonoX/ and http://www.mono-software.com/blog/post/Mono/95/Building-a-custom-ASP-NET-project-based-on-MonoX/
This content has not been rated yet. 
7207 Reputation 956 Total posts
qurban

qurban

2/14/2012 9:42:09 AM
Thanks a lot. The way i am working is not creating website in IIS. I don't have environment on my local system, neither i have SQL Server on my local machine. We are using TFS and SQL server is network based server which we accessed via IP. I am not looking to use TFS at this stage. All i want to create website in VS 2010 and start playing with it especially i want to create new web parts. I can't find any help for this scenario. I can not find any help to use Sample Solution and Unzipped MonoX 4 bundle.

I want to start custom solution. Sample solution is available in the download bundle but i am missing some point.

Do i need to combine MonoX bundle and Sample Solution files? I can't find any help like step by step that about custom Solution?

thanks in advance for your help?

*** Edited :

Some more questions;

-> I just created a copy of New folder in module gallery and renamed it "TestNews". Compiled successfully but i can't see any New Tab in part catalog.
-> When i click Blog tab, it shows 7 parts whereas folder 12 controls.
-> I tried to put Hello World part in different folders but i can't see in web part catalog.

***

thanks
This content has not been rated yet. 
203 Reputation 15 Total posts
khorvat

khorvat

2/14/2012 3:16:36 PM
Just to summarize the things from the session we had, we have performed a few more steps to install a MonoX and everything went ok (it was a bit slow but that depends upon the SQL Server connection speed), we have opened a custom solution and prepared everything so you can start building your custom WebParts.

If you have any other questions please open a new topic, I'm closing this one.

Regards
Rated 5.00, 1 vote(s). 
15993 Reputation 2214 Total posts