MonoX support board

Start the conversation, ask questions and share tips and solutions with fellow developers.

Non-registered users can only browse through our support boards. Please register now if you want to post your questions. It takes a second and it is completely free. Alternatively, you can log in without registration using your credentials at major sites such as Google, Microsoft Live, OpenId, Facebook, LinkedIn or Yahoo.

error during navigation  (Mono Support )

Viewed 18929 time(s), 8 post(s) 6/1/2011 7:04:25 AMby rensonsunny
rensonsunny

rensonsunny

6/1/2011 7:04:25 AM
Hi all,

I am using Monox product. During testing i have found one problem in navigation. I will explain the scenario.

step1: I logged in as user X. and click on tabs About and lets socialize and then logged out

step2: Then I logged in as user Y. and click on about and lets soicialize tab links. then logged in status of old user X is displayed. But the actual logged in user is User Y.

sometimes it also not displaying any logged in satus. (that is, actually user is logged in but in those pages ,option for log-in is showing. not displaying the user status. it is not regularly)

I found issue only in About(Features.aspx) and Lets Socilize(Dashboard.aspx)

Please give me one solution for this. I want to solve this problem

Regards
Renson Sunny
This content has not been rated yet. 
30 Reputation 4 Total posts
khorvat

khorvat

6/1/2011 8:56:47 AM
Hi,

can you please make sure that this isn't a browser cache issue, and in the meanwhile our QA team is testing the issue and we will get back to you.

Regards
This content has not been rated yet. 
15993 Reputation 2214 Total posts
rensonsunny

rensonsunny

6/1/2011 9:23:45 AM
I already checked..no..its not a browser cache issue..
This content has not been rated yet. 
30 Reputation 4 Total posts
imarusic

imarusic

6/1/2011 9:34:29 AM
Hi,

we got the same thing now during the test. It's related to the MonoX caching. We are working on it and will get back to you ASAP.

Regards.
This content has not been rated yet. 
3016 Reputation 428 Total posts
denis

denis

6/1/2011 11:13:11 AM
It appears that a "VaryByCustom" parameter is missing from the cache configuration for that page. MonoX server side caching (do not mix it with client-side browser cache) can operate on both page and Web part levels. "Let's socialize" page by default has page-level (output) caching turned on to minimize the impact of loading user avatars, blog posts and groups. You can specify different "VaryBy" parameters to control how it behaves - it basically wraps the default ASP.NET functionality described at this URL: http://msdn.microsoft.com/en-us/library/hdxfb6cy(v=VS.100).aspx
By default, MonoX varies the output cache by the application ID, language, user roles (since administrators and other groups usually have a totally different view of a same page), and a target page URL. In this case, since the page holds a user name, it must be varied by user also.
You have several choices here: to turn the page cache off, to add caching on the Web part level (in the Web part properties) or to add the varybycustom user parameter. Page cache is controlled in the page management section (/MonoX/Admin/PageAdmin.aspx, you must be logged in as an admin), find the page in the right pane (its title is Social Networking), right click on it and choose Page properties. You will be able to see the Cache tab in the page properties screen, so either set Cache duration to 0, or enter user in the Vary by custom field.
This content has not been rated yet. 
7207 Reputation 956 Total posts
rensonsunny

rensonsunny

6/1/2011 1:10:06 PM
Thank u all...thanx for ur support and valid information. Now the issue is solved.
This content has not been rated yet. 
30 Reputation 4 Total posts
rensonsunny

rensonsunny

6/3/2011 5:12:13 AM
Hi,

I have done the changes based on you told. Issue solved in local machine. then i upoladed it in cloud with same project and database. But again issue is showing. then what will be the issue. Plaese give me one solution for this.

Regards
renson KS
This content has not been rated yet. 
30 Reputation 4 Total posts
denis

denis

6/3/2011 8:20:13 AM
Hi,
It is highly unlikely that this could happen again if you uploaded the database version in which the page cache setting for this page is changed. Could you send me a private message with the site address and login details so I could take a look?
This content has not been rated yet. 
7207 Reputation 956 Total posts