MonoX support board

Start the conversation, ask questions and share tips and solutions with fellow developers.

Non-registered users can only browse through our support boards. Please register now if you want to post your questions. It takes a second and it is completely free. Alternatively, you can log in without registration using your credentials at major sites such as Google, Microsoft Live, OpenId, Facebook, LinkedIn or Yahoo.

Personalization is not enabled and/or modifiable  (Mono Support )

Viewed 11917 time(s), 3 post(s) 4/9/2013 8:58:58 AMby Zoomicon

Related topics

Zoomicon

Zoomicon

4/9/2013 8:58:59 AM
1) if I paste "Personalization is not enabled and/or modifiable. The Enabled property must be set to true, and a registered personalization provider must be selected. The current user must be granted the right to modify personalization state." in this site's search box I get a browser error page saying "bad request" (HTTP error?). Is it some security feature of ASP.net that thinks this is too long input for the search box? If there's a limit why don't you add a maxlen there?

2) after upgrading older DB to use with newer MonoX I get:

Personalization is not enabled and/or modifiable. The Enabled property must be set to true, and a registered personalization provider must be selected. The current user must be granted the right to modify personalization state.

why?

also, during upgrade from 4.7.40.3540 (run scripts 3715 to 3842) I get error when running
01. Fix_Blog_Slug_IX.sql
The CREATE UNIQUE INDEX statement terminated because a duplicate key was found for the object name 'dbo.Blog' and the index name 'IX_Slug'. The duplicate key value is (Creating-ClipFlair-activities).
The statement has been terminated.

and had to ignore that upgrade script - however I don't think this is causing the issue, I think I've seen something about personalization here before, but can't spot it at the moment with the search
Rated 5.00, 1 vote(s). 
2793 Reputation 345 Total posts
Zoomicon

Zoomicon

4/9/2013 1:22:49 PM
thanks, fixed as per suggestion at http://www.mono-software.com/Mono/Pages/Discussion/dtopic/ufN8D5aBikCDpqFlAZaScg/Personalization-failure/?dmsgId=EsBw0sxIFUObDqGbAQMlRw#PostEsBw0sxIFUObDqGbAQMlRw by clearing the all users personalization table at the db (since I couldn't log in to do from admin console). The per user one was empty already.
This content has not been rated yet. 
2793 Reputation 345 Total posts
khorvat

khorvat

4/9/2013 2:50:30 PM
Fixed the URL by modifying the title, glad that everything worked out.
This content has not been rated yet. 
15993 Reputation 2214 Total posts