MonoX support board

Start the conversation, ask questions and share tips and solutions with fellow developers.

Non-registered users can only browse through our support boards. Please register now if you want to post your questions. It takes a second and it is completely free. Alternatively, you can log in without registration using your credentials at major sites such as Google, Microsoft Live, OpenId, Facebook, LinkedIn or Yahoo.

Personalization failure?  (Mono Support )

Viewed 8566 time(s), 17 post(s) 2/14/2013 10:14:46 PMby Zoomicon
Zoomicon

Zoomicon

4/9/2013 10:44:01 AM

since I can't start the website I guess I can't use admin console
or is there possibility to use some special url and go to admin console directly without that error occuring?

unless you mean I have to clone the curren live site at other machine and then log in there, strip personalization info from admin console, then upgrade site and db. Sounds long way if there is a way I can edit the db by hand.

* do you have some script I can run at sql server to remove personalization data or is thete some stored procedure that does it?

thanx in advance

This content has not been rated yet. 
2793 Reputation 345 Total posts
khorvat

khorvat

4/9/2013 11:15:05 AM
Yes you can do it by hand, you can just delete the ASP.NET membership personalization table data - aspnet_PersonalizationPerUser, aspnet_PersonalizationAllUsers this will remove everything from personalization. If you don't want to do that you can find the path of your page in the aspnet_Paths table and then delete personalization for only that path.

Let me know if you need anything else.
This content has not been rated yet. 
15993 Reputation 2214 Total posts
Zoomicon

Zoomicon

4/9/2013 12:34:21 PM
I guess you mean to clean that table, not delete it, right?
This content has not been rated yet. 
2793 Reputation 345 Total posts
khorvat

khorvat

4/9/2013 1:14:09 PM
Yup, "you can just delete the ASP.NET membership personalization table data " :)
This content has not been rated yet. 
15993 Reputation 2214 Total posts
Zoomicon

Zoomicon

4/9/2013 1:18:43 PM
Thanks, emptied the all users personalization table and it seems to work now

not sure what the problem was though, since I couldn't visit any page of the site, even a new one (Home.aspx) that we had created by hand after the database snapshot (so it couldn't be trying to apply personalization data on it).

I looked for the pathid of default.aspx in the personalization data, but with a quick look couldn't find it (also there were 57 entries in there and not sure why they were needed, probably were left overs from monox demo site for pages that had been removed or something)
This content has not been rated yet. 
2793 Reputation 345 Total posts
khorvat

khorvat

4/9/2013 1:22:43 PM
Mixing MonoX demo pages and your custom pages can induce this kind of behavior because MonoX has saved demo page zone and data and you are trying to load your own data. This happens especially when you remove or add new zones and existing data expect old zone to be present.

I'm glad that you fixed the problem and that your site is back online.

Regards
This content has not been rated yet. 
15993 Reputation 2214 Total posts
Zoomicon

Zoomicon

6/2/2014 2:17:05 PM

since I've just needed this again, mentioning here the SQL script used to clear those tables for other users' convenience:

DELETE FROM aspnet_PersonalizationAllUsers

DELETE FROM aspnet_PersonalizationPerUser

(info on DELETE SQL command at http://www.w3schools.com/sql/sql_delete.asp)

obviously have to execute this on MonoX2 database

Rated 5.00, 2 vote(s). 
2793 Reputation 345 Total posts
1 2