MonoX support board

Start the conversation, ask questions and share tips and solutions with fellow developers.

Non-registered users can only browse through our support boards. Please register now if you want to post your questions. It takes a second and it is completely free. Alternatively, you can log in without registration using your credentials at major sites such as Google, Microsoft Live, OpenId, Facebook, LinkedIn or Yahoo.

I have latest monox up and running.. Error when trying to design or edit profile pages  (Mono Support )

Viewed 89791 time(s), 28 post(s) 1/14/2011 1:00:08 AMby shawndg
shawndg

shawndg

2/14/2011 9:27:41 PM
Hello,

When I launch a profile page.. If I try to edit edit mode I am getting a error...

URL Location..
http://localhost/devsite/profile/JoeR/?UserName=JoeR& 


[ArgumentException: The parameter 'username' must not contain commas.
Parameter name: username]
System.Web.Util.SecUtility.CheckParameter(String& param, Boolean checkForNull, Boolean checkIfEmpty, Boolean checkForCommas, Int32 maxSize, String paramName) +3904013
System.Web.Security.Membership.GetUser(String username, Boolean userIsOnline) +56
MonoSoftware.Web.Security.Membership.GetProviderUserKey(String userName) +810
MonoSoftware.MonoX.Pages.SocialNetworking.UserProfile.Page_Init(Object sender, EventArgs e) +417
System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e) +25
System.EventHandler.Invoke(Object sender, EventArgs e) +0
System.Web.UI.Page.OnInit(EventArgs e) +105
MonoSoftware.MonoX.BasePage.OnInit(EventArgs e) +123
System.Web.UI.Control.InitRecursive(Control namingContainer) +133
System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +1954


Im not sure why this is happening.. It even happens if view a profile page and then login from the profile page to monox..

Im running windows 7, iis7, and ,net 4.0
This content has not been rated yet. 
1871 Reputation 252 Total posts
denis

denis

1/14/2011 10:55:37 AM
This is very strange. It appears that URL rewriting is not functional for some reason on your portal, since the format of the URL is not correct. Can you confirm that you have a file Form.broser in the App_Browsers folder?
Are other URL rewritten sections functional (blog, for example)? What happens when you try to enter a new blog post?
This content has not been rated yet. 
7207 Reputation 956 Total posts
shawndg

shawndg

2/15/2011 11:59:03 AM
yes I do have the file.. and it contains the following code..

<adapterType="MonoSoftware.MonoX.UrlRewriter.FormRewriterControlAdapter" />

This content has not been rated yet. 
1871 Reputation 252 Total posts
shawndg

shawndg

1/14/2011 4:32:20 PM
I get a error when i try a blog post..

Object reference not set to an instance of an object

I just installed
http://learn.iis.net/page.aspx/460/using-the-url-rewrite-module/

But still no luck.... was kinda just a shot in the dark..
This content has not been rated yet. 
1871 Reputation 252 Total posts
shawndg

shawndg

1/14/2011 5:06:42 PM
I was wondering.. If maybe If it may be a bad idea to try to use .net 4.0 on monox just yet and instead use the optimum settings you have been using during development..

IIS Version ?
Database Version ?
.NET Version ?

Has monox been fully tested with .net 4.0 ? and IIS7 ? or are there still maybe some issues other then config files I may be able to avoid by just setting up my dev machines to pre-approved and tested configurations.

IIS7
Windows 7 / MS 2008 Server
MS SQL 2008 DATABASE
.NET 4.0 ?

I'm a developer so by nature I always want to run the greatest and bestest.. But I also understand testing and QAing products and I'm realistic.. So if it is recommended for me to run this on .net 3.5, change the OS, ETC or something.. then that is not a problem either.

I just want to make sure the product is ready for .net 4.0 before attempting to deploy it into a potentially production environment.

This content has not been rated yet. 
1871 Reputation 252 Total posts
denis

denis

2/14/2011 9:30:07 PM
MonoX fully supports both frameworks. At this moment we have more projects working on .NET 3.5, but this is going to change very soon, so there should be no .NET 4-specific issues.

Your problem is not caused by framework differences - it is caused by a problem in URL rewriting. MonoX has its own URL rewriting module, so you don't have to install anything else. Something is not configured correctly - IIS 5.1 and 6.0 require additional steps to configure URL rewriting, however, IIS 7 and higher should work out of the box - as long as the following line in web.config remains untouched:

<modules runAllManagedModulesForAllRequests="true" />

I would suggest that one of our guys assist you via TeamViewer or similar remote assistance tool as soon as possible. It is difficult to troubleshoot machine-specific issues on the forum. Let me know if this would work for you.
This content has not been rated yet. 
7207 Reputation 956 Total posts
shawndg

shawndg

2/14/2011 9:32:18 PM
Ya i looked in my webconfig and found this...

<browsers>
  
  <browser refID="Default">
    <controlAdapters>
      <adapter controlType="System.Web.UI.HtmlControls.HtmlForm"
               adapterType="MonoSoftware.MonoX.UrlRewriter.FormRewriterControlAdapter" />
    </controlAdapters>
  </browser>
  
</browsers>

im using the 4.0 config that comes with mono..

I have teamviwer installed already so just let me know when your available.. Im around now for a little bit and will be around again tomorrow..

How would you like me to contact you..
This content has not been rated yet. 
1871 Reputation 252 Total posts
denis

denis

1/15/2011 1:02:44 PM
Please send an e-mail to our support address (support at mono-software.com) and we'll contact you as soon as possible.
This content has not been rated yet. 
7207 Reputation 956 Total posts
shawndg

shawndg

1/19/2011 7:40:02 PM
I sent a email off to your support department but I have yet to get a response..

Been a couple days.. I am going to try reinstalling it one more time to see if that fixes anything..

This content has not been rated yet. 
1871 Reputation 252 Total posts
denis

denis

1/20/2011 10:47:25 AM
Unfortunately, we did not receive it. I just sent you a message to the gmail address you registered with this forum.
This content has not been rated yet. 
7207 Reputation 956 Total posts
1 2 3