Mono Support Installation problem 

Viewed 67724 time(s), 6 post(s), 5/11/2011 2:14:06 PM - by nicher
5/11/2011 2:14:06 PM
130 Reputation 14 Total posts


I have tried to install MonoX in two ways and experiencing problems.

I now have full trust given on the sub-domain where I am hosting MonoX. My hosting provider has got the windows web app gallery embedded in the control panel so i can install MonoX from there but it will be only version 3.2.x. As I read the upgrade article here and I know it can be a bit complicated I want to start with the most up to date version to avoid creating myself more work later.

Using their web app gallery Monox loads and work ok as far as I've seen.

But when i removed this installation and copied all the files and created the database and created a virtual folder pointing to /MonoX - The system does not work.

I get an error when i go to the sub domain itself where MonoX is installed under the root directory. I get the same error when I use sub-domain/MonoX (the virtual folder).

As that supposed to load the installation it redirects me to automatically and there I am getting the error I am talking about:

Server Error in '/MonoX' Application.
Could not load file or assembly 'MonoSoftware.Web.WAO' or one of its dependencies. The system cannot find the file specified.
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.
Exception Details: System.IO.FileNotFoundException: Could not load file or assembly 'MonoSoftware.Web.WAO' or one of its dependencies. The system cannot find the file specified.

Why is it happening? I have copied the entire file structure into my sub-domain's root directory.

The only thing I had to change is to remove the medium trust bit from web.config altering such settings is not allowed by my hosting provider (and i have full trust now anyway).

Hope you can help.

Kind regards,

5/11/2011 3:02:16 PM
7207 Reputation 956 Total posts

Hi Noy,
It appears that the Web gallery version that is offered by many hosting providers is totally obsolete. Aditionally, the approval process for the upgraded versions recently became very slow, and we are in contact with Microsoft, trying to resolve this situation. Currently, the safest option is to download the newest version from our site.

As for the error you are getting, it is quite clear: there is no MonoSoftware.Web.WAO.dll file in the /bin folder of your application. It is a strange situation, since it comes in all installation packages - it must have been removed manually.. Could you verify that this file is missing on your server? Could you also let me know which version of MonoX is used?

5/13/2011 11:38:14 AM
130 Reputation 14 Total posts

Hi Denis,

I am using the version from

I had a check and MonoSoftware.Web.WAO.dll existed in the bin directory. I have actually deleted all files and transferred them again via FTP and I still get the same.

Beneath the error there was also another piece of information saying:

Assembly Load Trace: The following information can be helpful to determine why the assembly 'MonoSoftware.Web.WAO' could not be loaded.

WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog]

Not sure what it means.

And this is a bit of the stack trace which is displayed too:

Stack Trace:

[FileNotFoundException: Could not load file or assembly 'MonoSoftware.Web.WAO' or one of its dependencies. The system cannot find the file specified.]
System.RuntimeTypeHandle._GetTypeByName(String name, Boolean throwOnError, Boolean ignoreCase, Boolean reflectionOnly, StackCrawlMark& stackMark, Boolean loadTypeFromPartialName) +0
System.RuntimeTypeHandle.GetTypeByName(String name, Boolean throwOnError, Boolean ignoreCase, Boolean reflectionOnly, StackCrawlMark& stackMark) +64
System.RuntimeType.PrivateGetType(String typeName, Boolean throwOnError, Boolean ignoreCase, Boolean reflectionOnly, StackCrawlMark& stackMark) +58
System.Type.GetType(String typeName, Boolean throwOnError, Boolean ignoreCase) +65
System.Web.Compilation.BuildManager.GetType(String typeName, Boolean throwOnError, Boolean ignoreCase) +342
System.Web.Configuration.ConfigUtil.GetType(String typeName, String propertyName, ConfigurationElement configElement, XmlNode node, Boolean checkAptcaBit, Boolean ignoreCase) +52


I get the same error when i use the sub-domain root directory where all the files and folders are stored and also when i use sub-domain/MonoX as defined by the virtual directory...


5/13/2011 6:08:33 PM
7207 Reputation 956 Total posts

It seems that the initial installation messed something up in your site configuration. Can you check if your Application Pool is running under the integrated mode (I assume that your hoster is using IIS7)? The app pool should also run as the "NetworkService" user, not as AppPoolIdentity. It appears that it cannot read the contents of the /bin folder at all. Maybe it is a permission issue caused by copying the content of the site, but not assigning rights to the NetworkService user?

5/14/2011 12:48:58 PM
130 Reputation 14 Total posts

Hi Denis.

My hosting company checked it and they have found it was to due with the virtual directory I created which was pointing to the /MonoX folder inside the root folder where I installed MonoX. Here is what I was told earlier:

The problem was that you have installed MonoX into the root folder 'wwwroot' of your website, you then converted the 'monox' sub folder in to a Virtual Directory so that this sub folder was now it's own application and could therefore not access the 'bin' folder in the parent directory above.

After removing the 'monox' Virtual Directory the sub folder became part of the parent application and so could therefore access the 'bin' folder in the directory above.

I might have understood the manual wrong. It says:

use the Internet Information Services management utility (type inetmgr in the Start-Run box) to
create a new Web site or virtual folder for MonoX. If you are using a virtual folder, make sure that a
new application is created (Application Settings section in the Directory tab of the folder properties

So I created a virtual directory pointing to the /MonoX directory. It did not work even when I pointed it to the main root directory where MonoX is installed.

Could you explain maybe what you meant about the virtual directory? I also noticed that when I used the web app gallery installation no virtual directory was created...

In any case it is working now.


5/14/2011 1:06:13 PM
130 Reputation 14 Total posts

Hi Denis,

This was my mistake, a virtual directory should not have been created as I used the main (root) directory as the main MonoX directory. Got it now :)


This is a demo site for MonoX. Please visit Mono Software for more info.