MonoX support board

Start the conversation, ask questions and share tips and solutions with fellow developers.

Non-registered users can only browse through our support boards. Please register now if you want to post your questions. It takes a second and it is completely free. Alternatively, you can log in without registration using your credentials at major sites such as Google, Microsoft Live, OpenId, Facebook, LinkedIn or Yahoo.

Can't see the log fila (Closed) (Mono Support )

Viewed 25779 time(s), 7 post(s) 10/31/2013 9:19:58 PMby arbh89
arbh89

arbh89

10/31/2013 9:19:58 PM
Hi,

I have just install monox cms and i am trying to implement my own site, everything is running but when i get an error i can't see the description because there is not any log file in MonoX\ApplicationData\Logs  

Regards
This content has not been rated yet. 
226 Reputation 21 Total posts
kpeulic

kpeulic

11/1/2013 5:13:31 AM
You need to allow write permissions to this folder.
This content has not been rated yet. 
1849 Reputation 181 Total posts
khorvat

khorvat

11/1/2013 6:32:29 AM
You may also allow write permissions for ApplicationData & Upload folder. Write permissions should be granted to the account under which application pool is running.

Regards
This content has not been rated yet. 
15993 Reputation 2214 Total posts
arbh89

arbh89

11/1/2013 4:00:23 PM
I have give write permission to my apppool in ApplicatioData folder but the problem persists, just Cache folder can see and error page is telling that the error has been logged.

Regards.
This content has not been rated yet. 
226 Reputation 21 Total posts
khorvat

khorvat

11/4/2013 8:14:09 AM
Can you please check the EventViewer to see if there is any other error there and you can also turn off the customErrors in the web.config so we can see the exact exception that you get.

From
<customErrors mode="On" defaultRedirect="/MonoX/Pages/MonoX/Error.aspx">
To
<customErrors mode="Off" defaultRedirect="/MonoX/Pages/MonoX/Error.aspx">
Regards
Rated 4.00, 1 vote(s). 
15993 Reputation 2214 Total posts
mzilic

mzilic

11/4/2013 10:26:06 AM
Hello,

Additionally to what Kristijan has suggested can you please also ensure that in your MonoX root directory you have the following file: web.log4net.

Regards,
Mario
Rated 4.50, 2 vote(s). 
2218 Reputation 300 Total posts
arbh89

arbh89

11/4/2013 3:01:43 PM
Solved adding web.log4net file as Mario said.

Thanks

Regards
This content has not been rated yet. 
226 Reputation 21 Total posts