MonoX support board

Start the conversation, ask questions and share tips and solutions with fellow developers.

Non-registered users can only browse through our support boards. Please register now if you want to post your questions. It takes a second and it is completely free. Alternatively, you can log in without registration using your credentials at major sites such as Google, Microsoft Live, OpenId, Facebook, LinkedIn or Yahoo.

Friends page not loading in Mobile site (Closed) (Mono Support )

Viewed 16043 time(s), 9 post(s) 7/17/2013 1:32:42 PMby mev9669
mev9669

mev9669

7/17/2013 1:32:42 PM
Hi,

I am trying to load the friends page in the mobile version of the site but the page gives the below error.  can you please tell me what might cause this error?

Server Error in '/' Application.Object reference not set to an instance of an object.Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 

Exception Details: System.NullReferenceException: Object reference not set to an instance of an object.

Source Error: 

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.
Stack Trace: 

[NullReferenceException: Object reference not set to an instance of an object.]
MonoSoftware.MonoX.ModuleGallery.SocialNetworking.PeopleSearch.OnLoad(EventArgs e) +273
System.Web.UI.Control.LoadRecursive() +110
System.Web.UI.Control.LoadRecursive() +208
System.Web.UI.Control.LoadRecursive() +208
System.Web.UI.Control.LoadRecursive() +208
System.Web.UI.Control.LoadRecursive() +208
System.Web.UI.Control.LoadRecursive() +208
System.Web.UI.Control.LoadRecursive() +208
System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +3367
This content has not been rated yet. 
515 Reputation 67 Total posts
khorvat

khorvat

7/17/2013 2:10:39 PM
Can you let us know what MonoX version are you using ?
This content has not been rated yet. 
15993 Reputation 2214 Total posts
mev9669

mev9669

7/17/2013 2:28:06 PM
4.7.40.4136
This content has not been rated yet. 
515 Reputation 67 Total posts
mev9669

mev9669

7/18/2013 3:13:01 PM
Any progress on this?
This content has not been rated yet. 
515 Reputation 67 Total posts
kpeulic

kpeulic

7/18/2013 3:48:05 PM
Could you download the latest version of the MonoX (v4.8.40.4598) and try to synchronized the module  "..\MonoX\ModuleGallery\Mobile\PeopleSearch.ascx" with your version?
This content has not been rated yet. 
1849 Reputation 181 Total posts
mev9669

mev9669

7/26/2013 10:15:18 AM
I am trying to use this http://www.mono-software.com/Mono/Pages/Discussion/dtopic/fk_vqV39EUaRG56KATl6gQ/How-to-have-a-custom-register-page/?pageno=1&dmsgId=7H3rPEnUG0qv46IHAMLtXA#Post7H3rPEnUG0qv46IHAMLtXA to do the custom web part. But getting the below error

The type or namespace name 'DefaultResources' does not exist in the namespace 'Resources' (are you missing an assembly reference?)

<label style="width: 60%; margin: 0px; padding: 0px; display: inline; text-align: left;"
Line 81: for="<%= chNewsletter.ClientID %>">
Line 82: <%= Resources.DefaultResources.Registration_Label_NewsletterSubscription%></label>
Line 83: </dd>

Page markup:

<%@ Control Language="C#" AutoEventWireup="true" Inherits="ProjectName.Web.Project.WebParts.MembershipEditor"
    CodeBehind="MembershipEditor.ascx.cs" %>
<%@ Import Namespace="MonoSoftware.MonoX.Resources" %>
<%@ Register Src="/MonoX/Controls/TimeZonePicker.ascx" TagPrefix="monox" TagName="TimeZonePicker" %>

in code behind:

using System;
using System.Collections.Generic;
using System.Linq;
using System.Web;

namespace ProjectName.Web.Project.WebParts
{

    public partial class MembershipEditor : MonoSoftware.MonoX.ModuleGallery.MembershipEditor
    {
        protected void Page_Load(object sender, EventArgs e)
        {

        }
    }

}
This content has not been rated yet. 
515 Reputation 67 Total posts
kpeulic

kpeulic

7/26/2013 10:36:47 AM
You can try to change the:

<%= Resources.DefaultResources.Registration_Label_NewsletterSubscription%>
with the:

<%= MonoSoftware.MonoX.Resources.DefaultResources.Registration_Label_NewsletterSubscription%>
This content has not been rated yet. 
1849 Reputation 181 Total posts
Chuck

Chuck

7/8/2014 5:54:21 PM
I am getting this error in version 4.9.40.4906.  Can you offer any suggestions on how to correct this?
This content has not been rated yet. 
35 Reputation 5 Total posts
khorvat

khorvat

7/9/2014 6:56:13 AM
Chuck we will answer you on a separate thread that is more relevant to your MonoX version.

Regards
This content has not been rated yet. 
15993 Reputation 2214 Total posts