MonoX support board

Start the conversation, ask questions and share tips and solutions with fellow developers.

Non-registered users can only browse through our support boards. Please register now if you want to post your questions. It takes a second and it is completely free. Alternatively, you can log in without registration using your credentials at major sites such as Google, Microsoft Live, OpenId, Facebook, LinkedIn or Yahoo.

Getting Security Exception while creating new Page in Monox  (Mono Support )

Viewed 7503 time(s), 8 post(s) 4/23/2015 10:52:05 AMby abhi00729
abhi00729

abhi00729

4/23/2015 10:52:16 AM

Hi,

I am getting Security exception while creating a new page through monox UI admin login.

attached are the screen shots and details.

Please help,

regards.

This content has not been rated yet. 
127 Reputation 21 Total posts
abhi00729

abhi00729

4/24/2015 3:34:00 AM

Hi,

This is urgent.

Requesting your support ASAP.

Regards

This content has not been rated yet. 
127 Reputation 21 Total posts
dbogdan

dbogdan

4/24/2015 9:00:43 AM
Hi abhi00729,

In order to resolve your issue you'll have to add write permissions (of the application pool) to the folder in which you are trying to create a page.

Please try following steps:
1. Go to the desired folder. Folder in which you want to create page(s).
2. RightClick -> Properties -> Security(tab)
3. Click "Edit" -> Click "Add"
4. In the TextArea type "IIS APPPOOL\{YourMonoXApplicationPoolName}" (without quotation marks)
5. Click "Locations..."-> Select {Your PC Name} -> OK
6. Click "Check Names" -> OK
7. In the permissions grid click "Allow" checkbox on the Write permission
8. Apply.

It should  resolve your problem. Please let us know if you have some other issues related to the problem.

Regards,
Darjan Bogdan

This content has not been rated yet. 
231 Reputation 38 Total posts
abhi00729

abhi00729

4/24/2015 1:02:57 PM

Hi dbogdan,

Tried the above solution but result is still the same.

Also tried giving full permission to IIS_IUSRS, but no success with this also.

what else I can try?

Regards.

This content has not been rated yet. 
127 Reputation 21 Total posts
dbogdan

dbogdan

4/24/2015 2:16:46 PM
Hi abhi00729,

Do you host your application locally, or somewhere else? If you set write permissions appropriatelly (as described in previous post), it should work. However, please take into account that your issues may be caused by your hosting service. In other words, maybe you don't have priviliges to set write permissions on that particular folder. Also, please avoid setting up write permission on root application folder (i.e. "Portal").

Regards.
This content has not been rated yet. 
231 Reputation 38 Total posts
abhi00729

abhi00729

5/1/2015 10:43:59 AM

Hi dbogdan,

We have hosted this application locally and I religiously followed the steps written in the previous post.

Moreover I have administrator access on the machine on which I deployed this application.

The problem is still the same.

Please help.

Regards.

This content has not been rated yet. 
127 Reputation 21 Total posts
abhi00729

abhi00729

5/2/2015 11:08:36 AM

Hi

We are about go live and only stuck due to this problem.

Please support as we don't want miss our timeline.

Regards.

This content has not been rated yet. 
127 Reputation 21 Total posts
mzilic

mzilic

5/4/2015 4:34:41 PM
Hi,

Please try setting IIS APPPOOL\<app pool name> full permission for the folder.  Judging by your screenshot can you debug in the code and determine if the line above ContentSharingEngine is the one throwing the exception?

Regards
This content has not been rated yet. 
2218 Reputation 300 Total posts