MonoX support board

Start the conversation, ask questions and share tips and solutions with fellow developers.

Non-registered users can only browse through our support boards. Please register now if you want to post your questions. It takes a second and it is completely free. Alternatively, you can log in without registration using your credentials at major sites such as Google, Microsoft Live, OpenId, Facebook, LinkedIn or Yahoo.

Problem - with Monix - Error Config maybe ? Windows 7 with IIS 7  (Mono Support )

Viewed 138777 time(s), 13 post(s) 1/6/2011 3:56:23 PMby shawndg

Related topics



2/8/2011 4:23:15 PM
I am getting the exact same error as shawndg described in his initial post. However I am running on port 80 so that is not the problem. I am wondering if I am missing a needed feature under IIS (under Turn Windows Features on and off?)

Here is my situation. I am installing on a brand new Windows 7 box that has SQL 2008 and Visual Studio 2010 installed (along with misc development tools) and of course .Net 4.0 (no prior versions installed).

I have a fairly minimal IIS 7.5 install. In the Windows Features dialog under Internet Information Services, the following items are checked:

- Web Management Tools
. - IIS Management Console
- World Wide Web Service
. - Application Development Features
. . - .Net Extensibility
. . - ASP.NET
. . - ISAPI Extensions
. . - ISAPI Filters
. - Common HTTP Features
. . - Default Document
. . - HTTP Errors
. . - HTTP Redirection
. . - Static Content
. - Security
. . - Request Filtering
. . - Windows Authentication

I have expanded the MonoX Zip file under into wwwroot\MonoX and created that folder as an application using the .Net 4.0 app pool.

Initialially while trying to navigate to http://localhost/monox I was getting the 500.19 errors [url=] discussed elsewhere[/url]. I solved this by replacing the web.config in the /monox directory with the
web4.0.config file from \MonoX\MonoX\Samples\Solution as was hinted at above.

That is all i have done and now I am getting the error reported by shawndg:

System.ArgumentException: The virtual path '/Default.aspx' maps to another application, which is not allowed.

This content has not been rated yet. 
0 Reputation 3 Total posts


2/9/2011 5:05:31 PM
This is a follow-up to my previous post on this topic. I was able to work around the problem by explicitly navigating to http://localhost/monox/default.aspx. This got me into the installation wizard and I was able to complete the installation. MonoX is now installed and appears to be working fine. However, I still cannot navigate to the site simply as http://localhost/monox. I still need to specify default.aspx.
This content has not been rated yet. 
0 Reputation 3 Total posts


2/9/2011 5:11:17 PM
I have posted a reply on your other thread - let's try by using the ending slash (http://localhost/monox/) and see what is happening.
This content has not been rated yet. 
7207 Reputation 956 Total posts
1 2