MonoX support board

Start the conversation, ask questions and share tips and solutions with fellow developers.

Non-registered users can only browse through our support boards. Please register now if you want to post your questions. It takes a second and it is completely free. Alternatively, you can log in without registration using your credentials at major sites such as Google, Microsoft Live, OpenId, Facebook, LinkedIn or Yahoo.

Blog Post Links not working - Page Not Found (Closed) (Mono Support )

Viewed 10060 time(s), 3 post(s) 8/4/2011 8:41:49 PMby helmer
helmer

helmer

8/4/2011 8:41:58 PM
Hello,

I have installed the latest .net 3.5 version including patch zip. IIS 6.0, Windows 2003 Server.
All pages of the Demo Site seem to work except the Blog references.

The links for the existing blog posts (Cloud Storage, Fighting Spam, etc) do not work - Page Not Found.
For example, the URL for http://mydomain/Blog/post/MonoX/7/Cloud-storage-for-your-data/ does not exist on my installation, I have no such folder called Blog/.../..

Did I miss a step during installation for blogs?

Any help would be appreciated.

Thanks.
This content has not been rated yet. 
60 Reputation 5 Total posts
denis

denis

8/4/2011 9:02:01 PM
Hi,
MonoX blog Web parts (and many others like profile and groups) are using "rewritten" URLs - they do not have the .aspx extension - and you need to set the "wildcard mapping" in IIS so it could catch all requests, including the ones for "extensionless" resources. This feature is crucial for SEO and many other techniques. Note that this has to be done for IIS 5.1 and 6.0, IIS 7 can handle this automatically, via Web.config.

By default, only the .aspx and related files (.ashx, .asmx) are mapped to the ASP.NET runtime. You can change this by following tis procedure:
- right click on the Web site you want to administer, Properties, Home directory tab, Configuration button. Copy the executable path from one of the existing ASP.NET extensions (.asax, for example). Click on the insert button, paste the executable path you copied in the previous step, and uncheck "Verify that file exists". This should fix this problem
This content has not been rated yet. 
7207 Reputation 956 Total posts
helmer

helmer

8/5/2011 5:17:47 PM
Thank you Denis - That fixed it.
This content has not been rated yet. 
60 Reputation 5 Total posts