MonoX support board

Start the conversation, ask questions and share tips and solutions with fellow developers.

Non-registered users can only browse through our support boards. Please register now if you want to post your questions. It takes a second and it is completely free. Alternatively, you can log in without registration using your credentials at major sites such as Google, Microsoft Live, OpenId, Facebook, LinkedIn or Yahoo.


brake bug in IE11 and clipflair text editor  (Mono Support )

Viewed 12825 time(s), 8 post(s) 7/16/2014 12:28:04 PMby panos.pag
panos-pag

panos.pag

7/16/2014 12:28:04 PM
(MonoX v4.9.40.4845 [12/25/2013], DB v4.7.3842)

Hello, 

We are facing a rare problem when using the text editor (e.g. in editing posts) on IE11:

When ever we attemp to place a <br> tag (either by code or by direct writing (shift + enter)), when we hit "publish", this br is being doublicated as this: <br></br><br></br>

Thank you,
Panos
This content has not been rated yet. 
390 Reputation 35 Total posts
dbogdan

dbogdan

7/18/2014 1:04:29 PM
Hi Panos,

We are using Telerik's rich text editor (RadEditor), and it seems that RadEditor has specific behaviour regarding insertion of break tags.

To circumvent this issue please try to add host header in ISS 7 (website level):
Name = "X-UA-Compatible"
Value = "IE=EmulateIE10"

Or, you can insert Html Meta tag on a PreRender event (of Page that uses RadEditor):

HtmlMeta meta = new HtmlMeta();
meta.Attributes.Add("http-equiv", "X-UA-Compatible");
meta.Attributes.Add("content", "IE=EmulateIE10");
Page.Header.Controls.Add(meta);
Regards,
Darjan
This content has not been rated yet. 
231 Reputation 38 Total posts
Zoomicon

Zoomicon

8/22/2014 3:24:33 PM

thanks, added it to the IIS at "HTTP Response Headers" for the site. However, I see this site has the same issue, how come you don't use the same fix?

This content has not been rated yet. 
2793 Reputation 345 Total posts
Zoomicon

Zoomicon

8/22/2014 3:25:18 PM

(to be exact I see </br> inserted when I paste content to the editor, not sure if it's the same issue)

This content has not been rated yet. 
2793 Reputation 345 Total posts
Zoomicon

Zoomicon

8/26/2014 9:48:02 AM

the code looks like setting two separate values, why is that? on IIS just one value is needed as I confirmed by pressing F12 in IE and checking the engine dropdown at the left (it says IE10, not Edge anymore) when I have added

name:    X-UA-Compatible 

value:    IE=EmulateIE10

This content has not been rated yet. 
2793 Reputation 345 Total posts
dbogdan

dbogdan

9/9/2014 1:54:06 PM
Hi Zoomicon,

Thank you for your responses.
Regarding the pasted content into Editor, we will have to look into it and investigate thoroughly what's causing "<br />" problem since this is Telerik's control.

Regarding the existing problem on this site, we will take a look and fix it as soon as possible.

And regarding the last post, please could you be provide us with more info? (i.e. what code looks like setting separate values)

Regards,
Darjan
This content has not been rated yet. 
231 Reputation 38 Total posts
Zoomicon

Zoomicon

9/9/2014 8:27:01 PM

sorry, just noticed the code does:

HtmlMeta meta = new HtmlMeta();
meta.Attributes.Add("http-equiv", "X-UA-Compatible");
meta.Attributes.Add("content", "IE=EmulateIE10");
and then
Page.Header.Controls.Add(meta);
so it does add one entry to the header, it's just that the HtmlMeta entry it adds has two parts (in IIS admin console it's much easier, you don't see http-equiv and content, you just set X-UA-Compatible to be equal to IE=EmulateIE10
This content has not been rated yet. 
2793 Reputation 345 Total posts
mzilic

mzilic

9/10/2014 3:31:00 PM
There are multiple solutions to this problem.
1. In IIS as you mentioned
2. Via code
3. You could even just set it for your specific site in web.config:
<httpProtocol>
     <!-- the following are performance optimizations for IIS 7 and higher: remove unneccessary headers, apply client side caching (7 days) for static content and content compression. Remove the compression in case of unespected behavior. -->
     <customHeaders>
       <remove name="X-Powered-By" />
       <add name="X-UA-Compatible" value="IE=10" />
     </customHeaders>
   </httpProtocol>
Regards
This content has not been rated yet. 
2218 Reputation 300 Total posts