MonoX support board

Start the conversation, ask questions and share tips and solutions with fellow developers.

Non-registered users can only browse through our support boards. Please register now if you want to post your questions. It takes a second and it is completely free. Alternatively, you can log in without registration using your credentials at major sites such as Google, Microsoft Live, OpenId, Facebook, LinkedIn or Yahoo.

SignalR Nuget Error  (Mono Support )

Viewed 8382 time(s), 2 post(s) 2/16/2015 2:46:48 PMby Apocalypse
Apocalypse

Apocalypse

2/16/2015 2:46:48 PM
Attempted to install signalR from the Nuget Package Manager Console and i get the following error

Install-Package : Could not install package 'Microsoft.Owin.Security 2.1.0'. You are trying to install this package into a project that targets '.NETFramework,Version=v4.0', but the 
package does not contain any assembly references or content files that are compatible with that framework. For more information, contact the package author.

Steps involved

1)Start Visual Studio
2)Start New Project (I have attempted this step using .NET Versions 3.5, 4.0, 4.5, and 4.5.1 all with the same result)
3)Add new website to project (MonoX Website)
4)Install Signal R

Prerequisites: MonoX Website was downloaded and installed using the web Platform Installer at this location
http://monox.mono-software.com/Download/WebPi/MonoXFeed.xml



Full Stack Trace

PM> Install-Package Microsoft.AspNet.SignalR
Attempting to resolve dependency 'Microsoft.AspNet.SignalR.JS (≥ 2.2.0)'.
Attempting to resolve dependency 'jQuery (≥ 1.6.4)'.
Attempting to resolve dependency 'Microsoft.AspNet.SignalR.SystemWeb (≥ 2.2.0)'.
Attempting to resolve dependency 'Microsoft.AspNet.SignalR.Core (≥ 2.2.0)'.
Attempting to resolve dependency 'Newtonsoft.Json (≥ 6.0.4)'.
Attempting to resolve dependency 'Owin (≥ 1.0)'.
Attempting to resolve dependency 'Microsoft.Owin (≥ 2.1.0)'.
Attempting to resolve dependency 'Microsoft.Owin.Security (≥ 2.1.0)'.
Attempting to resolve dependency 'Microsoft.Owin.Host.SystemWeb (≥ 2.1.0)'.
Attempting to resolve dependency 'Microsoft.Web.Infrastructure (≥ 1.0.0.0)'.
Installing 'jQuery 1.6.4'.
Successfully installed 'jQuery 1.6.4'.
Installing 'Microsoft.AspNet.SignalR.JS 2.2.0'.
You are downloading Microsoft.AspNet.SignalR.JS from Microsoft, the license agreement to which is available at http://www.microsoft.com/web/webpi/eula/net_library_eula_ENU.htm. Check the package for additional dependencies, which may come with their own license agreement(s). Your use of the package and dependencies constitutes your acceptance of their license agreements. If you do not accept the license agreement(s), then delete the relevant components from your device.
Successfully installed 'Microsoft.AspNet.SignalR.JS 2.2.0'.
Installing 'Newtonsoft.Json 6.0.4'.
Successfully installed 'Newtonsoft.Json 6.0.4'.
Installing 'Owin 1.0'.
Successfully installed 'Owin 1.0'.
Installing 'Microsoft.Owin 2.1.0'.
You are downloading Microsoft.Owin from Microsoft, the license agreement to which is available at http://www.microsoft.com/web/webpi/eula/aspnetcomponent_rtw_enu.htm. Check the package for additional dependencies, which may come with their own license agreement(s). Your use of the package and dependencies constitutes your acceptance of their license agreements. If you do not accept the license agreement(s), then delete the relevant components from your device.
Successfully installed 'Microsoft.Owin 2.1.0'.
Installing 'Microsoft.Owin.Security 2.1.0'.
You are downloading Microsoft.Owin.Security from Microsoft, the license agreement to which is available at http://www.microsoft.com/web/webpi/eula/aspnetcomponent_rtw_enu.htm. Check the package for additional dependencies, which may come with their own license agreement(s). Your use of the package and dependencies constitutes your acceptance of their license agreements. If you do not accept the license agreement(s), then delete the relevant components from your device.
Successfully installed 'Microsoft.Owin.Security 2.1.0'.
Installing 'Microsoft.AspNet.SignalR.Core 2.2.0'.
You are downloading Microsoft.AspNet.SignalR.Core from Microsoft, the license agreement to which is available at http://www.microsoft.com/web/webpi/eula/net_library_eula_ENU.htm. Check the package for additional dependencies, which may come with their own license agreement(s). Your use of the package and dependencies constitutes your acceptance of their license agreements. If you do not accept the license agreement(s), then delete the relevant components from your device.
Successfully installed 'Microsoft.AspNet.SignalR.Core 2.2.0'.
Installing 'Microsoft.Web.Infrastructure 1.0.0.0'.
Successfully installed 'Microsoft.Web.Infrastructure 1.0.0.0'.
Installing 'Microsoft.Owin.Host.SystemWeb 2.1.0'.
You are downloading Microsoft.Owin.Host.SystemWeb from Microsoft, the license agreement to which is available at http://www.microsoft.com/web/webpi/eula/aspnetcomponent_rtw_enu.htm. Check the package for additional dependencies, which may come with their own license agreement(s). Your use of the package and dependencies constitutes your acceptance of their license agreements. If you do not accept the license agreement(s), then delete the relevant components from your device.
Successfully installed 'Microsoft.Owin.Host.SystemWeb 2.1.0'.
Installing 'Microsoft.AspNet.SignalR.SystemWeb 2.2.0'.
You are downloading Microsoft.AspNet.SignalR.SystemWeb from Microsoft, the license agreement to which is available at http://www.microsoft.com/web/webpi/eula/net_library_eula_ENU.htm. Check the package for additional dependencies, which may come with their own license agreement(s). Your use of the package and dependencies constitutes your acceptance of their license agreements. If you do not accept the license agreement(s), then delete the relevant components from your device.
Successfully installed 'Microsoft.AspNet.SignalR.SystemWeb 2.2.0'.
Installing 'Microsoft.AspNet.SignalR 2.2.0'.
You are downloading Microsoft.AspNet.SignalR from Microsoft, the license agreement to which is available at http://www.microsoft.com/web/webpi/eula/net_library_eula_ENU.htm. Check the package for additional dependencies, which may come with their own license agreement(s). Your use of the package and dependencies constitutes your acceptance of their license agreements. If you do not accept the license agreement(s), then delete the relevant components from your device.
Successfully installed 'Microsoft.AspNet.SignalR 2.2.0'.
Adding 'jQuery 1.6.4' to NinetyMinutesPlusBase.
Successfully added 'jQuery 1.6.4' to NinetyMinutesPlusBase.
Adding 'Microsoft.AspNet.SignalR.JS 2.2.0' to NinetyMinutesPlusBase.
Successfully added 'Microsoft.AspNet.SignalR.JS 2.2.0' to NinetyMinutesPlusBase.
Removing 'Newtonsoft.Json 5.0.5' from NinetyMinutesPlusBase.
Successfully removed 'Newtonsoft.Json 5.0.5' from NinetyMinutesPlusBase.
Adding 'Newtonsoft.Json 6.0.4' to NinetyMinutesPlusBase.
Successfully added 'Newtonsoft.Json 6.0.4' to NinetyMinutesPlusBase.
Adding 'Owin 1.0' to NinetyMinutesPlusBase.
Successfully added 'Owin 1.0' to NinetyMinutesPlusBase.
Adding 'Microsoft.Owin 2.1.0' to NinetyMinutesPlusBase.
Successfully added 'Microsoft.Owin 2.1.0' to NinetyMinutesPlusBase.
Adding 'Microsoft.Owin.Security 2.1.0' to NinetyMinutesPlusBase.
Uninstalling 'Microsoft.Owin.Security 2.1.0'.
Successfully uninstalled 'Microsoft.Owin.Security 2.1.0'.
Uninstalling 'Microsoft.Owin 2.1.0'.
Successfully uninstalled 'Microsoft.Owin 2.1.0'.
Uninstalling 'Owin 1.0'.
Successfully uninstalled 'Owin 1.0'.
Uninstalling 'Newtonsoft.Json 6.0.4'.
Successfully uninstalled 'Newtonsoft.Json 6.0.4'.
Uninstalling 'Microsoft.AspNet.SignalR.JS 2.2.0'.
Successfully uninstalled 'Microsoft.AspNet.SignalR.JS 2.2.0'.
Uninstalling 'jQuery 1.6.4'.
Successfully uninstalled 'jQuery 1.6.4'.
Install failed. Rolling back...
Install-Package : Could not install package 'Microsoft.Owin.Security 2.1.0'. You are trying to install this package into a project that targets '.NETFramework,Version=v4.0', but the 
package does not contain any assembly references or content files that are compatible with that framework. For more information, contact the package author.
At line:1 char:1
+ Install-Package Microsoft.AspNet.SignalR
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (:) [Install-Package], InvalidOperationException
    + FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PowerShell.Commands.InstallPackageCommand
 
This content has not been rated yet. 
177 Reputation 14 Total posts
idrazic

idrazic

2/17/2015 9:51:08 AM
Hi Apocalypse,

I think the error message is clear; it's not related to MonoX.
Your project needs to target .Net 4.5 or you need to install <2 version that targets .Net 4.0
https://github.com/SignalR/SignalR/issues/1723
Open project properties and change target framework.

Also there's a newer MonoX version available here

Regards,
Igor
This content has not been rated yet. 
1384 Reputation 152 Total posts