MonoX support board

Start the conversation, ask questions and share tips and solutions with fellow developers.

Non-registered users can only browse through our support boards. Please register now if you want to post your questions. It takes a second and it is completely free. Alternatively, you can log in without registration using your credentials at major sites such as Google, Microsoft Live, OpenId, Facebook, LinkedIn or Yahoo.

RPX problem (Closed) (Mono Support )

Viewed 14506 time(s), 8 post(s) 6/14/2011 10:08:19 AMby modenl
modenl

modenl

6/14/2011 10:08:19 AM
I used a ip address(http://67.160.11x.xxx/) instead of a domain name. Not sure if that affect.
I got the following errors when I try to access discussion/blog after using RPX to sign in.

"An error has occured in the application.This event has been logged and will be addressed by the maintenance department. We appreciate your patience.

To continue working with the application please click here"

Homepage/about page works fine. I guess it's related to user profile. How MonoX create an user profile based on RPX login?

Nothing logged in the log file.
This content has not been rated yet. 
21 Reputation 3 Total posts
denis

denis

6/14/2011 10:29:27 AM
You checked the log file at /Monox/ApplicationData/Logs and it is empty? That is strange - maybe you did not grant the write permissions on that folder to the user account your W3WP process runs under (NETWORK SERVICE or something similar). What about Windows Event Log?

In any case, Janrain/RPX web part requires that you create your account at janrain.com and than follow the instructions to properly setup the login providers to work with it. Their service checks the domain name the authentication request is coming from, and for security reasons it does NOT work out of the box from third party domain names or IPs (there is a warning text displayed in that module). You will have to configure the web part by entering your own API key (you'll be able to read it on the Janrain's site) and configure each provider (Facebook, Twitter, etc) using their admin panel.
This content has not been rated yet. 
7207 Reputation 956 Total posts
modenl

modenl

6/14/2011 10:44:34 AM
MonoX_Info.log has only 1 line: "2011-06-14 02:38:39,913 [4] INFO MonoX [BaseHttpApplication] - Application Start
2011-06-14 02:50:16,605 [14] INFO MonoX [BaseHttpApplication] - Application End"
It doesn't look like a permission issue. Nothing logged in windows event log either.

I've setup my account at janrain. I've configed google/yahoo provider. I've added my ip to the whitelist. Api key is set in Login.aspx:
<td id="rowRPX" class="login-right-section" runat="server" Visible="<% $Code: MonoSoftware.MonoX.ApplicationSettings.EnableUserRegistration %>">
<MonoX:LoginRpx runat="server" ID="ctlLoginRpx" Width="100%" ApiKey="d1beebe5******************8670ec"
RpxFrameUrl="http://bemasters.rpxnow.com/openid/embedd" />
<div class="login"><asp:Literal runat="server" Visible="<% $Code: MonoSoftware.MonoX.ApplicationSettings.EnableUserRegistration %>" Text="<% $Code: PageResources.Login_RpxWarning %>"></asp:Literal></div>
</td>

RPX login succeed. But I got this error if I click on discussion/blog or user profile.
This content has not been rated yet. 
21 Reputation 3 Total posts
denis

denis

6/14/2011 11:16:33 AM
Is there a MonoX.log file (not MonoX_info.log) in that folder, as all error messages would go to it?
It appears that you are logged on to a site despite the error message? Is there a user record for that RPX user in the database (go to the admin panel, users section to search for it)? MonoX creates a user record and all associated records for all users, so that would rule out the problems on the Janrain's side.
This content has not been rated yet. 
7207 Reputation 956 Total posts
denis

denis

6/14/2011 11:29:55 AM
Additionally, I have found the Janrain log message related to your site (as it logs all unapproved domains)  - it appears to be sent before you made the neccessary changes. I have tried to log in to your site via RPX and using my Google account and it went without any problems.
This content has not been rated yet. 
7207 Reputation 956 Total posts
modenl

modenl

6/15/2011 5:56:01 AM
I did a clean installation again. It seems solved the problem...
Thanks very much denis!

This content has not been rated yet. 
21 Reputation 3 Total posts
denis

denis

6/14/2011 4:56:21 PM
Which version of MonoX are you using?
This may have nothing to do with RPX, I am not able to reproduce this behavior locally. Are you able to access other pages (except home)? Can you access blog and discussion when logged in "normally" (without RPX)?
Blog and discussion pages both use URL rewriting to some extent, and since your logs are empty it may have something to with it.
This content has not been rated yet. 
7207 Reputation 956 Total posts
denis

denis

6/14/2011 4:59:31 PM
I was writing my response and did not see your latest post - glad to hear that it is solved!
This content has not been rated yet. 
7207 Reputation 956 Total posts