MonoX support board

Start the conversation, ask questions and share tips and solutions with fellow developers.

Non-registered users can only browse through our support boards. Please register now if you want to post your questions. It takes a second and it is completely free. Alternatively, you can log in without registration using your credentials at major sites such as Google, Microsoft Live, OpenId, Facebook, LinkedIn or Yahoo.

web.config issues  (Mono Support )

Viewed 4875 time(s), 3 post(s) 6/2/2014 1:58:04 PMby Zoomicon
Zoomicon

Zoomicon

6/2/2014 1:58:04 PM

1) I think web.config should use 2 space indenting to avoid making it too long a horizontal scroll to read (and also maybe break down some long entries to more lines)

2) has mixed casing in true/false (some are True/False), makes it harder to compare, you have to set ignore case but that might make you miss some other change that may be case sensitive

3) upload types list is missing ".pptx" file extension (only has ".ppt")

4) at the end I have:

  <!-- CLIPFLAIR: NEWER AJAX TOOLKIT -->
</br>  <runtime>
</br>    <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
</br>      <dependentAssembly>
</br>        <assemblyIdentity name="AjaxControlToolkit" publicKeyToken="28f01b0e84b6d53e" culture="neutral" />
</br>        <bindingRedirect oldVersion="0.0.0.0-3.0.30930.28736" newVersion="4.1.60623.0" />
</br>      </dependentAssembly>
</br>    </assemblyBinding>
</br>  </runtime>

thought it wouldn't be needed anymore, but I see you still have older AjaxControlToolkit dll in the bin folder?

This content has not been rated yet. 
2793 Reputation 345 Total posts
Zoomicon

Zoomicon

6/2/2014 2:03:40 PM

your AjaxControlToolit.dll was 20Jun2012, mine ws 24Jun2012 in date, but their version was way different (mine was 4.x, yours much lower, 3.x)

btw, regarding formatting the .config file, Visual Studio's edit menu can do it (fix the indenting to 2 and the casing of True/False). One just sets in VS settings / Text Editor / All languages the indent to 2 and to "use spaces" (instead of tabs), then goes to Edit menu of VS and select Advanced / Format document

This content has not been rated yet. 
2793 Reputation 345 Total posts
dbogdan

dbogdan

6/3/2014 12:25:44 PM
Hi Zoomicon,

Thank you for your issue report. We will take these issues into a consideration.

Regards,
Darjan Bogdan
This content has not been rated yet. 
231 Reputation 38 Total posts