MonoX support board

Start the conversation, ask questions and share tips and solutions with fellow developers.

Non-registered users can only browse through our support boards. Please register now if you want to post your questions. It takes a second and it is completely free. Alternatively, you can log in without registration using your credentials at major sites such as Google, Microsoft Live, OpenId, Facebook, LinkedIn or Yahoo.

Email not sent during Messaging each other in MonoX CMS  (Mono Support )

Viewed 22398 time(s), 6 post(s) 8/12/2014 7:24:30 AMby pulak
pulak

pulak

8/12/2014 7:24:30 AM
Hi Team,
I have send message other users using messaging system in  MonoX CMS. But they are not getting any messages in their email address though their are using valid email address.

I have modify the email setting in web.confg file as like (with valid credentials)
<system.net>
    <mailSettings>
      <smtp deliveryMethod="Network" from="donotreply@xxx">
        <network defaultCredentials="false" host="smtp.xxxx.com" port="xxx" enableSsl="true" password="XXX"/>
      </smtp>
    </mailSettings>
  </system.net> 
and also
set
Enable SSL true in admin => portal settings section .

Is there anything I am missing there ? 
 
Please help!
 


This content has not been rated yet. 
69 Reputation 6 Total posts
imarusic

imarusic

8/12/2014 7:34:20 AM
Hi,

can you please check MonoX logs for the eventual exceptions? You can find Monox logs in: 

~\MonoX\ApplicationData\logs

You should also set permissions to Application data folder if there are not log entries.

Regards.
This content has not been rated yet. 
3016 Reputation 428 Total posts
pulak

pulak

8/12/2014 9:48:45 AM
Yes, I am getting the following error message in log file.
--------------------------------------------------------------------------------------------------------------------
2014-08-12 07:00:42,104 [11] ERROR MonoX [115.119.137.130] - Error
System.Security.SecurityException: Security error.
   at MonoSoftware.MonoX.BasePage.OnInit(EventArgs e)
   at System.Web.UI.Control.InitRecursive(Control namingContainer)
   at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
The Zone of the assembly that failed was:
MyComputer
2014-08-12
07:41:50,496 [32] ERROR MonoX [admin] - An error has occured while
sending you an e-mail. Please try again, if the problem
persists, please contact us.
   at MonoSoftware.MonoX.Mail.MonoXMailSender.SendMail(MailMessage mailMsg)
   at MonoSoftware.MonoX.Repositories.MessageRepository.SendMailToUser(Guid messageId, MailMessage mailMsg)
Failure sending mail.
   at System.Net.Mail.SmtpClient.Send(MailMessage message)
   at MonoSoftware.Core.Mail.MailSender.SendMail(MailMessage mailMsg)
The remote name could not be resolved: 'mail.yourdomain.com'
at System.Net.ServicePoint.GetConnection(PooledStream PooledStream,
Object owner, Boolean async, IPAddress& address, Socket&
abortSocket,
Socket& abortSocket6)
   at System.Net.PooledStream.Activate(Object owningObject, Boolean async, GeneralAsyncDelegate asyncCallback)
   at System.Net.ConnectionPool.GetConnection(Object owningObject, GeneralAsyncDelegate asyncCallback, Int32 creationTimeout)
   at System.Net.Mail.SmtpConnection.GetConnection(ServicePoint servicePoint)
   at System.Net.Mail.SmtpClient.Send(MailMessage message)
---------------------------------------------------------------------------------------------------------------------------
What should I do to resolved it?
This content has not been rated yet. 
69 Reputation 6 Total posts
imarusic

imarusic

8/12/2014 9:53:30 AM
This seems like an issue:

The remote name could not be resolved: 'mail.yourdomain.com'
Can you check you mail settings section web.config file?
This content has not been rated yet. 
3016 Reputation 428 Total posts
pulak

pulak

8/12/2014 10:37:59 AM
Hi,
 I have checking there. There no such keywords in mail section web.config  file.

mail settings are look like as :
<system.net>
    <mailSettings>
      <smtp deliveryMethod="Network" from="noreply@xxx.xx">
        <network defaultCredentials="false" host="mx1.xx.xx" port="25" enableSsl="true" password="xxxx" />
      </smtp>
    </mailSettings>
   Is there any chance to store it in diff location / database  as well?
 
This content has not been rated yet. 
69 Reputation 6 Total posts
idrazic

idrazic

8/12/2014 11:53:45 AM
Hi Pulak

Can you tell us if this is set to true?
<add key="EnableSmtpSSL" value="false"/>
Also see discussions here for possible solution:
Activation-Email-Fails-to-Send-Arvixe-Hosting
User-registration-OAuth-and-install-from-zip
Problem-with-smtp-and-activation-e-mail

>>   Is there any chance to store it in diff location / database  as well?
You can store it in a separate configuration file
<mailSettings>
  <smtp configSource="Configuration\Production\smtp.config" />
</mailSettings>
smtp.config
<?xml version="1.0"?>
<smtp deliveryMethod="Network" from="noreply@xxx.xx">
    <network defaultCredentials="false" host="mx1.xx.xx" port="25" enableSsl="true" password="xxxx" />
</smtp>
Regards,
Igor

This content has not been rated yet. 
1384 Reputation 152 Total posts